[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#50411: debconf should be upgraded first.

reassign 50411 debconf
retitle 50411 dpkg-preconfig should do basic dependnacy check

Seth R Arnold wrote:
> I think apt-get upgrade should make upgrading debconf a high priority,
> higher than most other packages. I have seen three times, on two different
> computers, apt-get upgrade fail because a certain package must have
> pre-depended on a certain version of debconf, without actually specifying
> the Predepend: debconf (>>x.xx). The error messages are non-intuitive at the
> least.

No, apt should not treat debconf specially. Debconf is going to be modified
to detect packages that try to use newer versions of it than are available,
and skip preconfiguring them.

see shy jo

Reply to: