[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: compilation of (gnome-)apt

On 28 Feb 1999, Christian Leutloff wrote:
> My first problem was, that the configure step for apt requires
> xpm. Okay I installed the Debian xpm, but nothing changed. There is no
> libxpm available within Debian 8-(. Which Debian package is here
> needed? Can it be suggested with the error message!? In the meantime I
> used --without-x to get apt compiled successfully.

It's called xpm4g-dev, I think.
> /usr/include/libgnomeui/gnome-canvas.h:19: libart_lgpl/art_misc.h: No such file or directory
> /usr/include/libgnomeui/gnome-canvas.h:20: libart_lgpl/art_rect.h: No such file or directory
> IMHO this indicates a broken gnome development environment. Any hints
> or should I wait for the next gnome updates!?

My guess is that you need libart-dev, or something like that.
libgnomeui-dev should probably depend on it but I guess it doesn't (you
could file a bug if it turns out that it does, because as you can see it
is required). 

The current Gnome should be fine except that the popup menu is broken in
gnome-apt due to a library bug. If you get the newer Gnome the popup menu
will work.


Reply to: