[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Pkg-xfce-devel] Bug#830522: xfce4-session: re-login fails with dbus connection error



Same here, exactly as described by Ben.


Kernel:              Linux 4.6.0-1-amd64 (x86_64)
Compiled:            #1 SMP Debian 4.6.2-2 (2016-06-25)
Distribution:        Debian GNU/Linux stretch/sid
Desktop Environment: XFCE 4


On Sat, 09 Jul 2016 09:33:21 +1200 Ben Caradoc-Davies <ben at transient.nz>
wrote:
> Package: xfce4-session
> Version: 4.12.1-4
> Severity: normal
> 
> Dear Maintainer,
> 
> xfce4 login via lightdm succeeds, but after logout, logging in again fails with
> first this dialog:
> 
> "Unable to contact settings server. Failed to connect socket /tmp/dbus-
> XXXXXXXXXX: connection refused."
> 
> and after pressing OK, the second dialog.
> 
> "Unable to load a failsafe session. Unable to determine failsafe session name.
> Possible causes: xfconfd isn't running (D-Bus setup problem); environment
> variable $XDG_CONFIG_DIRS is set incorrectly (must include "/etc"), or xfce-
> session is installed incorrectly."
> 
> Repeatable every time. Problem persists over reboots. Workaround is to shutdown
> and restart. Using the default XDG_CONFIG_DIRS=/etc/xdg
> 
> I suspect recent dbus upgrades.
> 
> Kind regards,
> Ben.
> 
> 
> 
> -- System Information:
> Debian Release: stretch/sid
>   APT prefers unstable
>   APT policy: (500, 'unstable')
> Architecture: amd64 (x86_64)
> Foreign Architectures: i386
> 
> Kernel: Linux 4.6.0-1-amd64 (SMP w/4 CPU cores)
> Locale: LANG=en_GB.utf8, LC_CTYPE=en_GB.utf8 (charmap=UTF-8)
> Shell: /bin/sh linked to /bin/dash
> Init: systemd (via /run/systemd/system)
> 
> Versions of packages xfce4-session depends on:
> ii  libatk1.0-0            2.20.0-1
> ii  libc6                  2.23-1
> ii  libcairo2              1.14.6-1+b1
> ii  libdbus-1-3            1.10.8-1
> ii  libdbus-glib-1-2       0.106-1
> ii  libfontconfig1         2.11.0-6.4
> ii  libfreetype6           2.6.3-3+b1
> ii  libgdk-pixbuf2.0-0     2.34.0-1
> ii  libglib2.0-0           2.48.1-1
> ii  libgtk2.0-0            2.24.30-2
> ii  libice6                2:1.0.9-1+b1
> ii  libpango-1.0-0         1.40.1-1
> ii  libpangocairo-1.0-0    1.40.1-1
> ii  libpangoft2-1.0-0      1.40.1-1
> ii  libpolkit-gobject-1-0  0.105-15
> ii  libsm6                 2:1.2.2-1+b1
> ii  libwnck22              2.30.7-5
> ii  libx11-6               2:1.6.3-1




Reply to: