[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Pkg-xfce-devel] Bug#747340: Bug#747340: xfce4-taskmanager freezes on armhf architecture

I have tried strace. It produced a lot of output, most text lines
had this text:

read(7, "", 1024)                       = 0

I ran xfce4-taskmanager with gdb from the shell, pressed CRTL-C after
xfce4-taskmanager freezed and did a backtrace in gdb. Unfortunately
there is no package with debug symbols for xfce4-taskmanager so that I
only got the following output:

#0  0xb680162c in read () from /lib/arm-linux-gnueabihf/libc.so.6
#1  0xb67c966c in _IO_file_underflow () from
#2  0xb67ca1f8 in _IO_default_uflow () from
#3  0xb67ca118 in __uflow () from /lib/arm-linux-gnueabihf/libc.so.6
#4  0xb67c4148 in getc () from /lib/arm-linux-gnueabihf/libc.so.6
#5  0x00013454 in ?? ()
#6  0x00013454 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

I will see if this bug also occurs when I build xfce4-taskmanager from
source (Debian source package).


Moritz Strohm

On 07. mai 2014 18:44, Yves-Alexis Perez wrote:
> Can you try to get a backtrace with gdb or strace it to see what
> happens? You'll have to do most of the work yourself here, we dont have
> an harmhf box handy for that?
> Regards,
> Yves-Alexis

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 897 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-xfce-devel/attachments/20140507/555f83ab/attachment.sig>

Reply to: