[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Pkg-xfce-devel] Bug#638898: xfce4-xkb-plugin: Second keyboard layout removed after a while, have to keep resetting it



Package: xfce4-xkb-plugin
Version: 0.5.4.3-1+b1
Followup-For: Bug #638898

FWIW

it is REALLY annoying and pretty much rendering this plugin unusable... 
having workaround is good but I wish it could be really fixed for the wheezy...
checked upstream git and I guess resolution boiled down to

fb667951f66a05b87949b3eaf9e7c04697899fea
Author: Igor Slepchin <igor.slepchin at gmail.com>  2012-07-17 16:13:40
Committer: Igor Slepchin <igor.slepchin at gmail.com>  2012-07-24 15:38:38
Follows: 0.5.4.3

    Remove configuration of keyboard layouts.
    
    Keyboard layouts are moved to xfce4-keyboard-settings.
    The management of layouts per application/window
    is still handled by this plugin.
    
    Compose key configuration is gone for now; might get reinstated
    in xfce4-keyboard-settings.
    
    This fixes bug 5476 (together with a corresponding commit
    to xfce4-settings).


unfortunately changes in xfce4-settings were not as atomic and there is a
series of related commits (if I got it right).

But I guess someone could consider this issue 'fixed-upstream'

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (900, 'testing'), (600, 'unstable'), (300, 'experimental'), (100, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.2.0-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages xfce4-xkb-plugin depends on:
ii  libc6               2.13-33
ii  libcairo2           1.12.2-2
ii  libgdk-pixbuf2.0-0  2.26.1-1
ii  libglib2.0-0        2.32.3-1
ii  libgtk2.0-0         2.24.10-1
ii  libpango1.0-0       1.30.0-1
ii  librsvg2-2          2.36.1-1
ii  libwnck22           2.30.7-1
ii  libxfce4ui-1-0      4.8.1-1
ii  libxfce4util4       4.8.2-1
ii  libxklavier16       5.2.1-1
ii  xfce4-panel         4.8.6-3

xfce4-xkb-plugin recommends no packages.

xfce4-xkb-plugin suggests no packages.

-- no debconf information




Reply to: