[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Pkg-xfce-devel] Bug#651495: analysis



Karsten Merker provides the following analysis of this bug:

  Xfce4-mixer did not work out of the box. On start, it complained
  that "GStreamer was unable to detect any sound devices".  The
  reason for this was that the gstreamer0.10-alsa package was not
  installed.  This problem has already been submitted by somebody
  else in bug #651495 last year; the problem has been confirmed by
  another submitter in June 2012 and is still open.  This should be
  fixed before the wheezy release, in particular as xfce is now the
  default desktop for wheezy.  From a first look at the issue it
  seems that there is no explicit dependency on gstreamer0.10-alsa
  in task-xfce-desktop.  Xfce4-mixer itself depends on
  "gstreamer0.10-alsa | gstreamer0.10-audiosink", whereby
  gstreamer0.10-audiosink is a purely virtual package provided by
  other gstreamer-plugins, so if some other application pulls in
  e.g. gstreamer0.10-plugins-good, the dependency gets fulfilled
  but the mixer nonetheless does not work on an alsa device.

I will be working around this in task-xfce-desktop, I suppose, but
am leaving this bug open where it is, since the same situation
can be obtained without using tasksel.

-- 
see shy jo
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-xfce-devel/attachments/20120902/7d75a431/attachment.pgp>



Reply to: