[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Pkg-xfce-devel] Debian testing installs with XDM as dependency of Xfce fail (eventually) when switched to LightDM

I'm sorry for the long subject line.

This is a weird one, but I've got the chains of events pretty well 
documented. Since I have an obvious workaround (using XDM) I'm only 
reporting this in case someone thinks diagnosing the problem might be 
helpful to the packaging effort.

I started to report this on the LightDM list, but Yves-Alexis suggested 
I was off-topic there. I have to admit that I'm stumped on deciding just 
where the problem is.

I'll limit my discussion to the five Debian testing systems I maintain 
for my office and for my family.

Three of these systems were installed back when GDM was the default DM 
for Xfce during installation. Two of them were installed after XDM 
became the default DM for Xfce.

GDM (version 2) was removed from testing. At that point I tried the 
three older installations with GDM3, SLiM, XDM, and (eventually) LightDM 
when it became available in the main repositories. Those three older 
installations have never had any reliability issues whatsoever with any 
of those DMs.

However, the two recent installations -- one AMD64 and one i386 from 
daily build #7 from 20110815, both having been installed from 
businesscard images -- will not work reliably with LightDM.

When I first install LightDM and switch to using it (I've been letting 
aptitude handle this at install time.) everything seems fine. All of the 
policy behaviors (poweroff and reboot available to non-root, ability to 
mount and umount drives from Thunar, etc.) work perfectly. But when I 
shut these systems down or log off, I see this message on TTY1:

Init ID: "co" respawning too fast: disabled for 5 minutes

In the beginning, the error is only displayed only once. Over a period 
of a couple of days I start to see the list of this repetitive error 
getting longer and longer when shutting down, rebooting, logging off. 
Finally, I'll see the list get long enough to cover the screen 
top-to-bottom. I know that when I see that, the next session is going to 
lock up on me.

I log back on, and the system hard locks -- no response whatsoever to 
keyboard or mouse. I force it to power off using the power button.

After this I will not be able to start Xfce normally when I restart and 
log in. Instead, the background stays on the same image that's behind 
the login prompt, and an X cursor appears. The cursor moves, but there 
is no desktop environment present, no Alt-F2, no panel, no ability to do 
anything except switch to a TTY and start trying to diagnose / fix the 

Note that after rebooting I CAN log in to another profile (that hasn't 
been in regular use). I still have a fully functioning Xfce at that 
point, but I also see the ominous "co" respawning too fast message, too. 
Just not as many iterations. And I strongly suspect the other profile 
would eventually fail in the same manner as the USERID 1000 one did.

A couple of times I have tried things like deleting the ~/.cache and 
~/.config in the ailing profile. That restores functionality to the 
profile for another couple of days, and then it fails to start Xfce in 
the same manner again.

If I install XDM and set it as the default DM, the system comes up to 
the desktop properly after the login -- this is without cleaning the 
profile, so it's hard to blame Xfce, I think.

I have cycled through this three times now. Install LightDM, remove XDM, 
have LightDM fail to start Xfce after a couple of days. Reinstall XDM, 
remove LightDM, everything works perfectly. Rinse, repeat.

If someone wants to walk me through an approach to diagnosing this, I'll 
be happy to try to co-operate -- bearing in mind that I'm actually 
trying to use the two troubled workstations for doing work.

If you think that this is possibly due to some gremlin in the original 
installation / dependencies setup I'll just wait until LightDM has been 
made of dependency of the Xfce desktop, and then try clean installations.

Bear in mind that I saw someone running Xubuntu (I forget the version.) 
over on the LightDM list complaining about what sounded to me like 
pretty much the same issue, so I'm thinking the problem may also not be 
distro-specific to Debian.

It's just weird.

Reply to: