[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Pkg-xfce-devel] Bug#547623: thunar: MS Office .doc treated as plain text document which means OOo doesn't launch rather text editor

On Sat, 2009-11-21 at 11:13 +0100, Yves-Alexis Perez wrote:
> My guess would be that it's the same bug as 504147. The mimetype
> position in mimeinfo.cache might be important.
> In yours. text/plain is at line 57 and application/msword at line 47
> which means (if I believe last comments in #504147) that there might be
> an ?alias? bug.
> Could you try to move the text/plain to the very first lines (at least
> before application/msword), and run update-desktop-database (as root).
> Then logout, log back in and report back.

It's not the same bug.  I tried editing mimeinfo.cache, and I tried
running Thunar with the patch from #504147, with no results.  In
#504147, thunar_vfs_mime_database_get_applications was being passed the
correct MIME type for the file but was failing to look up the right
applications.  In this bug, thunar_vfs_mime_database_get_applications is
being passed the wrong MIME type (text/plain for a Word document and
video/x-theora+ogg for a Vorbis file).

John Lindgren

Reply to: