[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libinput: Changes to 'refs/tags/libinput-1.0.1-1'



Tag 'libinput-1.0.1-1' created by Timo Aaltonen <tjaalton@debian.org> at 2015-09-03 08:52 +0000

Tagging upload of libinput 1.0.1-1 to unstable.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAABAgAGBQJV6ApJAAoJEMtwMWWoiYTcgMMP/RT32TI3gPmg+6BipS8L9EuS
D1zCGf0hJCJf2T3TwUNID1AUV3Up6u7Esy46+/y904jrbfNeMgZrNCb/kf/RkeM5
xIpM8Mx4cIkkWLBVnVKbOGaoXgCKUjd50l1SV+NMgkSTd1vBF2JiMAKY3Q7+RjGq
t2AwE2sO3Ud4z2WGWwWo63qkiX6Pw3OQz2blMkkqTedzodTTurqOlF1NgkOJeVkM
mYbYV8SLAnY4/YwFbP239EPrrSd4lHUBSc6nqrztaKR9idnnpeDhCUwqU1L9YQ/K
bCy9hQTDH5pv4q55awDLEQyda2Go8uRw2nKoMsGGFPBWfKjZskBEENcCgoMD4Iiy
oI3VaCbsWwNFCvy5wqSmDtbaeSUmcRe/dnrnQnN+fJQlfvL1yPwgQOJGswCrPLSA
9dpxapr4vBrJ/Fysj3jvXAVJl3paFH4hZF4UjUul8myQI/aeYg+HOSzZL/pSMeZ2
uxwcYx/JG6yR7vleufhPZcPqezGbv2RaDtnechE22Z0gV4leoawP6EmMB05BzYxP
i7DMOT2SDQDPU9zHrveP6pI+knLBJ1q+G3+wtoEqjH7SQv2m/H3yv24f9h5VgqN7
NTqER8cjas3BsT/XOPkY2P9z8uEfm9H9nR+Kk/bKxGjCXY/hU7t9sM8GBsO6dRgX
VIYxrW7C3D2Ow/wRJMKq
=5B1W
-----END PGP SIGNATURE-----

Changes since libinput-0.21.0-1:
Andreas Pokorny (3):
      doc: inverse event type restriction of x and y accessors
      doc: ellipse instead of ellipsis
      test: fix gcc warning about missing prototypes

Jackie Huang (1):
      configure.ac: add arg --with-libunwind

Jason Gerecke (1):
      doc: fix more typos

Peter Hutterer (41):
      middle-button: don't call libinput_now() in the timeout handler
      filter: fix acceleration threshold assignment
      test: don't try to print axis values that aren't set
      udev: use prop_value() to fetch the ID_INPUT_PROP property
      evdev: split scroll threshold and direction lock threshold into two
      Revert "filter: move the pointer acceleration profiles back to units/ms"
      filter: drop superfluous struct declaration
      filter: rename speed to speed_adjustment where it's in the [-1,1] range
      filter: rename speed_out to "factor" for the touchpad profiles
      filter: add two helper functions to convert between speeds
      filter: explain the acceleration function in detail
      filter: drop accel->last, write-only value
      filter: move create_pointer_accelerator_filter down in the file
      filter: revamp to create device-specific filters, rather than accel functions
      filter: split calculating the accel factor into a helper function
      filter: split out handling of the low-dpi accel method
      touchpad: enable natural scrolling for edge scrolling
      filter: duplicate the code for the Lenovo x230 accel method
      filter: split trackpoint acceleration out
      tools: allow filter-switching in ptraccel-debug
      doc: add pointer acceleration documentation
      tools: add shell script for making the pointer acceleration graphs in the docs
      test: add a comment
      Merge branch 'filter-us-ms-cleanup'
      doc: fix typos
      evdev: drop relative x/y motion from a device not marked as pointer
      tools: fix switch statement indentation
      Change a fprintf to log_error
      Drop obsolete unused declarations for log_info/set_logging_enabled
      Add log_*_ratelimit wrappers
      test: use the touchpad size for the 7mm movement
      test: fix edge scroll timeout test
      filter: use named initalizers for the accelerator interface
      filter: move the TP_MAGIC_SLOWDOWN to a single definition
      filter: add a "filter_constant" hook to the filter interface
      touchpad: use unaccelerated motion data for scrolling
      configure.ac: libinput 1.0RC1
      doc: add a diagram for evemu and note that libinput doesn't recordings
      configure.ac: libinput 1.0
      filter: fix constant acceleration for the X230
      configure.ac: libinput 1.0.1

Timo Aaltonen (3):
      Merge branch 'upstream-unstable' into debian-unstable
      update the changelog
      release to unstable

---
 configure.ac                             |   27 
 debian/changelog                         |    6 
 doc/Makefile.am                          |    6 
 doc/absolute-axes.dox                    |    2 
 doc/dot/evemu.gv                         |   19 
 doc/faqs.dox                             |    2 
 doc/gestures.dox                         |    2 
 doc/normalization-of-relative-motion.dox |    6 
 doc/page-hierarchy.dox                   |    1 
 doc/palm-detection.dox                   |    4 
 doc/pointer-acceleration.dox             |  110 
 doc/reporting-bugs.dox                   |    8 
 doc/seats.dox                            |    4 
 doc/svg/ptraccel-linear.svg              | 5486 +++++++++++++++++++++++++++++++
 doc/svg/ptraccel-low-dpi.svg             | 3748 +++++++++++++++++++++
 doc/svg/ptraccel-touchpad.svg            | 1723 +++++++++
 doc/svg/ptraccel-trackpoint.svg          | 3689 ++++++++++++++++++++
 doc/tapping.dox                          |    2 
 doc/tools.dox                            |    4 
 doc/touchpads.dox                        |    6 
 src/evdev-middle-button.c                |    4 
 src/evdev-mt-touchpad-edge-scroll.c      |   23 
 src/evdev-mt-touchpad-gestures.c         |    3 
 src/evdev-mt-touchpad.c                  |   27 
 src/evdev-mt-touchpad.h                  |    4 
 src/evdev.c                              |   71 
 src/evdev.h                              |   11 
 src/filter-private.h                     |    8 
 src/filter.c                             |  591 ++-
 src/filter.h                             |   44 
 src/libinput-private.h                   |   14 
 src/libinput-util.h                      |    6 
 src/libinput.c                           |   30 
 src/libinput.h                           |   12 
 test/device.c                            |  155 
 test/litest-int.h                        |    4 
 test/litest.c                            |   21 
 test/touchpad.c                          |  111 
 tools/Makefile.am                        |    2 
 tools/make-ptraccel-graphs.sh            |   79 
 tools/ptraccel-debug.c                   |   48 
 tools/shared.c                           |  244 -
 udev/libinput-model-quirks.c             |    2 
 43 files changed, 15986 insertions(+), 383 deletions(-)
---


Reply to: