[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libxkbcommon: Changes to 'refs/tags/xkbcommon-0.3.0'



Tag 'xkbcommon-0.3.0' created by Daniel Stone <daniel@fooishbar.org> at 2013-04-01 17:16 +0000

Bug fixes and minor API tweaks.

Changes since xkbcommon-0.2.0:
Damien Lespiau (2):
      build: Make autoreconf honour ACLOCAL_FLAGS
      build: Require xorg macros 1.16

Daniel Stone (14):
      README updates
      More README
      Only distribute .tar.xz archives
      Parser: Initialise geometry elements for VarDecl
      test: Move test_key_seq to common.c
      test: Add flags argument to test_get_context()
      test: Use test_get_context() in log.c
      Add environment overrides for default RMLVO
      test: Suppress RMLVO environment inheritance by default
      test: Add environment checking to rulescomp
      Allow NULL rmlvo for xkb_keymap_new_from_names
      test: Add va_list variant of test_key_seq
      Add key-sequence checking to rulescomp
      Bump version to 0.3.0

David Herrmann (1):
      keymap: add xkb_keymap_new_from_buffer()

Ran Benita (78):
      state: fix possible index-out-of-bounds in action dispatch table
      test: add key processing benchmark
      configure.ac: add explicit PKG_PROG_PKG_CONFIG
      configure.ac: don't tramp on user's CFLAGS
      Makefile.am: split sed script into multiple lines
      Makefile.am: move test.h to libtest_la_SOURCES
      state: don't use xkb_state_serialize_* internally
      doc: fix wrong comment
      state: don't use xkb_keymap_num_layouts internally
      state, context: allow passing NULL to *_unref()
      test/keyseq: add test for setting depressed group
      action: don't allow private actions with a known type
      Add some explanations on consumed modifiers
      keysym-utf: also translate special keysyms like Tab and Return
      keysym-utf: mark keysymtab array as static
      doc: clarify that keysym_to_utf8 returns size including '\0'
      test/keysym: '\e' is non-standard
      Don't use trailing enum comma in public headers
      keymap: wrap the layout parameter if it is out of range for the key
      state: don't keep the previous state components in xkb_state
      state: rename state->cur to state->components
      configure.ac: add xkbcommon.com url to AC_INIT
      Sync test data from xkeyboard-config
      test/keyseq: re-add de(neo) level5 test
      test/interactive: also print the level
      state: fix unbound virtual modifier bug
      test/interactive: change variable name for 'xkb' to 'keymap'
      Change 'indicator' to 'led' everywhere possible
      symbols: fix bad 'merge' assignment
      ast: constify argument
      symbols: make it clear which 'dflt' is meant
      compat: make it clear which 'dflt' is meant
      action: s/hndlrType/handler_type
      keycodes: some minor style
      Change some log functions to take ctx instead of keymap
      keysym: print unicode keysyms uppercase and 0-padded
      Fix dead assignments
      ast: add error handling to XkbFileFromComponents
      keymap-dump: style cleanups
      keymap-dump: don't indent after xkb_keymap {
      keymap-dump: remove some ugly empty lines
      keymap-dump: move writing 'key {}' in symbols to its own function
      Makefile.am: don't create INSTALL and ChangeLog
      Remove list.h
      keycodes: fix spelling in error message
      ast-build: remove malloc_or_die
      parser: also skip 'section' ELEMENT
      test/rmlvo-to-kccgst: free memory before exit
      More spelling errors
      text: clean up and fix the *MaskText functions
      text: some style changes
      keymap: abstract a bit over the keymap format
      Don't try to build linux-specific tests on non-linux
      Build cleanly with clang
      xkbcomp: handle XKB file include's better
      keycodes: remove unneeded alias conflict check
      Move a couple of general keymap functions from keycodes.c
      state: small style fix
      keycodes: don't do unnecessary copies while merging
      keymap: don't use darray for key aliases
      keycodes: remove file_id
      keycodes: unwrap KeyNameInfo
      keycodes: remove KeyNamesInfo::merge
      types: put all copy-to-keymap code in one function
      types: remove file_id
      compat: remove file_id
      symbols: remove file_id
      Remove file_id entirely
      Fix pointer style nit
      keymap: rename xkb_kt_map_entry to xkb_key_type_entry
      doc: some improvements
      doc: update Doxyfile template to one from newer version
      doc: use README as doxygen main page overview
      state: use stdbool in filters
      keyseq: add a couple of tests
      rules: quiet a gcc warning
      rules: be more paranoid in scanner
      xkbcomp/keymap: silence a gcc warning

---
 Makefile.am                        |   57 
 README                             |   17 
 configure.ac                       |   41 
 doc/Doxyfile.in                    |  126 -
 src/context.c                      |   85 
 src/context.h                      |   28 
 src/darray.h                       |    6 
 src/keymap.c                       |  254 ++
 src/keymap.h                       |   57 
 src/keysym-utf.c                   |   39 
 src/keysym.c                       |    8 
 src/list.h                         |  489 ----
 src/state.c                        |  302 +-
 src/text.c                         |  238 +-
 src/text.h                         |    2 
 src/xkbcomp/action.c               |   34 
 src/xkbcomp/ast-build.c            |  242 +-
 src/xkbcomp/ast-build.h            |    8 
 src/xkbcomp/ast.h                  |    9 
 src/xkbcomp/compat.c               |  308 +-
 src/xkbcomp/include.c              |   48 
 src/xkbcomp/include.h              |    5 
 src/xkbcomp/keycodes.c             |  531 ++---
 src/xkbcomp/keycodes.h             |   37 
 src/xkbcomp/keymap-dump.c          |  444 ++--
 src/xkbcomp/keymap.c               |   16 
 src/xkbcomp/parser.y               |   32 
 src/xkbcomp/rules.c                |   26 
 src/xkbcomp/scanner.l              |   32 
 src/xkbcomp/symbols.c              |  145 -
 src/xkbcomp/types.c                |  153 -
 src/xkbcomp/xkbcomp-priv.h         |   21 
 src/xkbcomp/xkbcomp.c              |  164 -
 test/.gitignore                    |    2 
 test/bench-key-proc.c              |   95 
 test/buffercomp.c                  |   10 
 test/common.c                      |  149 +
 test/context.c                     |    2 
 test/data/compat/default           |   12 
 test/data/compat/iso9995           |    4 
 test/data/keymaps/stringcomp.data  | 3815 ++++++++++++++++++-------------------
 test/data/keymaps/unbound-vmod.xkb | 1533 ++++++++++++++
 test/data/rules/base               |   75 
 test/data/rules/evdev              |   81 
 test/data/symbols/altwin           |   13 
 test/data/symbols/ca               |    5 
 test/data/symbols/de               |   36 
 test/data/symbols/il               |   80 
 test/data/symbols/in               |   75 
 test/data/symbols/inet             |    2 
 test/data/symbols/keypad           |   11 
 test/data/symbols/latin            |    2 
 test/data/symbols/level3           |   42 
 test/data/symbols/level5           |   26 
 test/data/symbols/pc               |    2 
 test/data/symbols/ru               |   13 
 test/data/symbols/rupeesign        |    5 
 test/data/symbols/us               |  163 +
 test/data/sync.sh                  |   63 
 test/data/types/level5             |    1 
 test/data/types/pc                 |    8 
 test/filecomp.c                    |   11 
 test/interactive.c                 |   24 
 test/keyseq.c                      |  196 -
 test/keysym.c                      |   21 
 test/log.c                         |    2 
 test/print-compiled-keymap.c       |    2 
 test/rmlvo-to-kccgst.c             |   15 
 test/rules-file.c                  |    2 
 test/rulescomp.c                   |  170 +
 test/state.c                       |    7 
 test/stringcomp.c                  |   12 
 test/test.h                        |   31 
 xkbcommon/xkbcommon.h              |  221 +-
 74 files changed, 6615 insertions(+), 4428 deletions(-)
---


Reply to: