[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#671812: xserver-xorg-core: segfault at exit

On Mon, May 07, 2012 at 10:49:02AM +0200, Cyril Brulebois wrote:
> Upgrading from 2:1.12.1-1? 

Right, and as Jakub points out, the segfault no longer occurs with
downgrade to 2:1.12.1-1

> Any chance you could get a full backtrace? See basic instructions on:
>   http://x.debian.net/howto/use-gdb.html
> Thanks already.
> Mraw,
> KiBi.

I tried following the guide first by adding "-core" to .xserverrc:

exec /usr/bin/X11/X :0 -br -nolisten tcp -auth .Xauthority -core

no core file was produced in /etx/X11 as far as I could see.

I then tried the two-machine approach by ssh'ing into my desktop from
laptop, attaching to X session, exit X session on desktop, reading
backtrace. However I'm afraid gdb is not playing nice either. The
backtraces do not seem to match ones in Xorg logs and they are
different each time I try shutting down X with debugger attached.

Clearly though I'm not doing something right as Jakub was able to get a

Reply to: