[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#648328: libgl1-mesa-dri: libGL error : dlopen /usr/lib/dri/r600_dri.so failed: dri not working

Package: libgl1-mesa-dri
Version: 7.11-6
Severity: grave
Justification: renders package unusable

Dear Maintainer,
*** Please consider answering these questions, where appropriate ***

   * What led up to the situation?

I wanted to give gnome3 a try but it didn't load.

   * What exactly did you do (or not do) that was effective (or

Setting LIBGL_DEBUG=verbose and running glxinfo showed that 
(/usr/lib/dri/r600_dri.so  : cannot open shared object file  : No such file or directory) 
So I looked for a file called r600_dri.so on my system and found two,
one in /usr/lib/x86_64-linux-gnu/dri and another one in /usr/lib32/dri
(both files are not identical). Doing a symbolic link to the first one
in /usr/lib/dri solved the problem (dri working)

This file is shipped by the libgl1-mesa-dri package but xorg (I guess)
is looking in the wrong place compared to the place this file is put.
Therefore I'm not sure if it's a xorg bug or a libgl1-mesa-dri one.

Best regards,

X server symlink status:
lrwxrwxrwx 1 root root 13 Sep 28  2007 /etc/X11/X -> /usr/bin/Xorg
-rwxr-xr-x 1 root root 2056592 Oct 20 16:15 /usr/bin/Xorg

VGA-compatible devices on PCI bus:
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV710 [Radeon HD 4350] [1002:954f]

/etc/X11/xorg.conf does not exist.

/etc/X11/xorg.conf.d does not exist.

KMS configuration files:
  options radeon modeset=1

Kernel version (/proc/version):
Linux version 3.0.0-1-amd64 (Debian 3.0.0-3) (ben@decadent.org.uk) (gcc version 4.5.3 (Debian 4.5.3-8) ) #1 SMP Sat Aug 27 16:21:11 UTC 2011

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.0.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_CH.UTF-8, LC_CTYPE=fr_CH.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libgl1-mesa-dri depends on:
ii  libc6           2.13-21   
ii  libdrm-intel1   2.4.26-1  
ii  libdrm-radeon1  2.4.26-1  
ii  libdrm2         2.4.26-1  
ii  libexpat1       2.0.1-7.2 
ii  libffi5         3.0.10-3  
ii  libgcc1         1:4.6.1-15
ii  libstdc++6      4.6.1-15  

libgl1-mesa-dri recommends no packages.

Versions of packages libgl1-mesa-dri suggests:
pn  libglide3  <none>

Versions of packages xserver-xorg depends on:
ii  libc6                                             2.13-21              
ii  virtualbox-guest-x11 [xorg-driver-video]          4.1.4-dfsg-1         
ii  x11-xkb-utils                                     7.6+4                
ii  xkb-data                                          2.1-2                
ii  xserver-xorg-core                                 2:       
ii  xserver-xorg-input-all                            1:7.6+9              
ii  xserver-xorg-input-evdev [xorg-driver-input]      1:2.6.0-2+b2         
ii  xserver-xorg-input-synaptics [xorg-driver-input]  1.4.1-1+b1           
ii  xserver-xorg-input-wacom [xorg-driver-input]      0.10.10+20110203-1+b2
ii  xserver-xorg-video-ati [xorg-driver-video]        1:6.14.2-2           
ii  xserver-xorg-video-fbdev [xorg-driver-video]      1:0.4.2-4+b2         
ii  xserver-xorg-video-mach64 [xorg-driver-video]     6.9.0-1+b1           
ii  xserver-xorg-video-r128 [xorg-driver-video]       6.8.1-5+b2           
ii  xserver-xorg-video-radeon [xorg-driver-video]     1:6.14.2-2           
ii  xserver-xorg-video-vesa [xorg-driver-video]       1:2.3.0-7+b1         

xserver-xorg recommends no packages.

Versions of packages xserver-xorg-core depends on:
ii  keyboard-configuration  1.70          
ii  libaudit0               1.7.18-1      
ii  libc6                   2.13-21       
ii  libdrm2                 2.4.26-1      
ii  libgcrypt11             1.5.0-3       
ii  libpciaccess0           0.12.1-2      
ii  libpixman-1-0           0.22.2-1      
ii  libselinux1             2.1.0-4       
ii  libudev0                172-1         
ii  libxau6                 1:1.0.6-3     
ii  libxdmcp6               1:1.1.0-3     
ii  libxfont1               1:1.4.4-1     
ii  udev                    172-1         
ii  xserver-common          2:

xserver-xorg-core recommends no packages.

Versions of packages xserver-xorg-core suggests:
ii  xfonts-100dpi    1:1.0.3  
ii  xfonts-75dpi     1:1.0.3  
ii  xfonts-scalable  1:1.0.3-1

Reply to: