[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#636135: Also affected

I'm also affected by this, after I switched to radeon (from fglrx). I'm using a Mobility Radeon HD 5650. This seems to happen regardless of the display port I'm using (VGA or HDMI) and of the screen. radeon is working pretty well otherwise. I'm using Linux 3.0 on i386 with the amd64 image.

In fact, I switched a month ago and hadn't noticed this problem until recently. This does not always happen when just "logging out of KDE", it happens when kdm resets X. That means this won't happen if you directly halt the PC from KDE. This also won't happen if you start a second session and use "Logout" from that session (as you'll be switched to the X server of the first session). I think the only case where this happens is if you have a single session open and close it without halting the PC. This must be a relatively rare scenario. One reason to do it would be to restart X or KDE without rebooting. Another case could be a user on a multi-user machine who's done and decides to logout so that his session won't consume memory when another user opens his session.

I tried the workaround and it worked. I just had to uncomment #TerminateServer=true in /etc/kde4/kdm/kdmrc (on line 513).

I can also confirm that blacklisting radeon solved... and oddly enough, that solution persists after removing radeon from the blacklist. I don't know how that can be. The only thing I see is that I played with desktop effects. Just after removing radeon from the blacklist, the black screen still wouldn't show, even though radeon was loaded, but I also wouldn't get desktop effects anymore. So I played with desktop effects a bit trying to get them back, and that eventually worked. I am now back to my original situation (radeon X driver with the radeon LKM loaded and firmware installed, KDE effects enabled), the only apparent thing changed is that I can logout of KDE without issues...

Also, the last time I saw the problem, I realized the same as oz reported, that is kdm is still working, it's just showing nothing. I was even able to login. Unfortunately, that didn't solve the problem. Xorg got to 100% CPU and I eventually restarted.

I looked for errors and there are sure a lot, but the only very suspicious chunk I found was:

klauncher(28046) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(28038)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed: "Not connected to D-Bus server"

I still wonder what this is about.

Reply to: