[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#645239: libgl1-mesa-dri: Please include the Nouveau drivers

Package: libgl1-mesa-dri
Version: 7.11-6
Severity: wishlist

I think it's time to install the Nouveau 3D drivers by default,
i.e. move them to the libgl1-mesa-dri package.  While not fully
supported for all cards (e.g. there is currently no upstream maintainer
for the classic Mesa driver and for nvfx), these drivers should give
most users a much better experience than the swrast driver.

With the advent of technologies as GNOME Shell and WebGL in web
browsers, out-of-the-box OpenGL support is also becoming more and more
important.  Besides, other current distributions (e.g. Ubuntu 11.10,
openSUSE 12.1 and Slackware 13.37) have also followed the Fedora 15 lead
to install the Nouveau 3D drivers by default.

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (101, 'experimental')
Architecture: i386 (x86_64)

Kernel: Linux 3.1.0-rc9-nouveau (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Reply to: