[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

xcb-util-wm: Changes to 'refs/tags/0.3.8'



Tag '0.3.8' created by Arnaud Fontaine <arnau@debian.org> at 2011-04-25 17:07 +0000

Release 0.3.8
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEABECAAYFAk21qmgACgkQvfKiIF42GdM58gCcCRTQrjWT6ZEygtE1knViHTYY
VVsAnRM1iTQ5TT+/+xzVcYIAxkXycgbT
=ALR3
-----END PGP SIGNATURE-----

Changes since the dawn of time:
Alan Coopersmith (5):
      Bug #7150: Check for gcc & Sun cc in configure.ac and use correct flags to turn on more warnings for each
      Make sure m4 supports -I flag, if not, try finding gnu m4
      Make xcb_icccm.h use the same type as icccm.c for gravity parameter
      Fix typos in various header comments
      Close leak in xcb_get_text_property_reply when reply->type == XCB_NONE

Arnaud Fontaine (74):
      [icccm]: fix incorrect pointer usage
      [icccm]: correctly copy the reply value according to its format
      [icccm]: Remove useless function for accessing 'flags' which were also
      [icccm] Make xcb_get_text_property() public as it might be useful for
      [atom] Move '*discriminated_atom*' functions from icccm to atom
      [icccm] Make xcb_get_text_property() and functions relying on it
      [icccm] Make xcb_get_wm_transient_for() asynchronous and document the code.
      [icccm] Make xcb_get_wm_size_hints() and xcb_get_wm_normal_hints()
      [icccm] Make xcb_get_wm_hints() asynchronous, remove useless functions
      [icccm] Make xcb_get_wm_protocols() asynchronous and document the
      [icccm] Fix namespace according to XCB code in general.
      [icccm] Add copyright notices.
      [icccm] Add functions to get WM_CLASS property.
      [icccm] Avoid InternAtom request.
      [icccm] Comment and indent the code properly.
      [icccm] Bump library version number to 0.3.0.
      icccm: use xcb_gravity_t when possible and cosmetic changes
      Check for ssize_t in configure for xcb-util-common.h
      Bump version to 0.3.6
      Add missing return values
      Bump version to 0.3.7
      icccm: atoms previously defined in xcb_atom are now defined in xproto
      Add AM_MAINTAINER_MODE for vendors
      xcb_get_text_property_reply() reply type could be XCB_NONE if the property is not present
      icccm: add missing setters for WM_CLASS and WM_TRANSIENT_FOR properties
      icccm: allow to set the encoding format for TEXT properties
      icccm: add WM_COLORMAP_WINDOWS
      icccm: fix inconsistency in prototypes of WM_PROTOCOLS setters
      Add xcb-util/ewmh library
      Allow per-connection EWMH information
      Add missing return values
      Clean up
      Clean up and add missing protypes
      Cosmetic
      Fix ClientMessage invalid data
      Cosmetic
      Get rid of unreadable shift in DO_REPLY_LIST_VALUES_ATOM
      Remove a macro in favor of inline functions
      Use countof() instead of the length value directly
      Cosmetic
      Cosmetic
      Remove UTF8 reply macro in favor of inline functions
      Use countof when possible
      Fix _NET_WM_STRUT and _NET_WM_STRUT_PARTIAL
      Use countof when possible
      Add missing _NET_WM_HANDLED_ICONS
      Use countof when possible and fix WM_SYNC_REQUEST_COUNTER
      Use sizeof() instead of plain integer
      Fix indentation and untabify
      Atoms previously defined in xcb_atom are now defined in xproto
      Fix indentation and change email address
      xcb_ewmh_send_client_message: use memcpy() instead of a loop and make data_len the length in bytes
      Fix compiler warning by casting the value to uint64_t before the shift
      Replace all the ugly if statements with a loop
      Make code generated by m4 more readable
      Fix typos on _NET_WM_SYNC_REQUEST_COUNTER functions and add it in the Atoms list
      Remove useless const
      A given connection may have several screens associated
      xcb_ewmh_send_client_message: check whether the data fit the ClientMessage
      xcb_ewmh_init_atoms: use xcb_setup_roots_length()
      xcb_ewmh_init_atoms: don't use VLA for wm_cm_sn declaration
      xcb_ewmh_get_wm_name_reply should have always been static
      Add missing inclusion of stdlib.h in EWMH header
      Rename time function parameter to xtime in to avoid clash with time.h
      Split up icccm and ewmh into their own repository
      Prefix all ICCCM public functions, types and macros by 'icccm'.
      Bump version to 0.3.8
      Add ewmh/ewmh.c and ewmh/xcb_ewmh.h to .gitignore as they are generated with m4
      Check more carefully the reply of a _NET_WM_ICON which may contains
      Fix unintialized variable for the number of icons
      Fix setters for _NET_WM_ICON to allow more than one icon.
      Untabify for consistency.
      Fix package name
      Release 0.3.8

Bart Massey (1):
      used doxygen -u to create a much more elaborate doxyfile

Bob Ham (1):
      Add a check on xproto version libxcb was compiled with

Dirk Wallenstein (1):
      Use an absolute URL for the m4 submodule

Donnie Berkholz (1):
      Add correct dependencies in xcb-util.

Eric Anholt (1):
      Move .cvsignore to .gitignore.

Gaetan Nadon (2):
      config: use the default xorg .gitignore file
      config: generate ChangeLog and INSTALL

Henning Sten (1):
      add more verbose explanation of the purpose of "encoding" parameter in doxygen documentation tag

Ian Osgood (4):
      Remove xcb-util dependency on proto/X11
      All xcb-util libraries compile after the Great Renaming.
      Install headers to "xcb", not "X11/XCB".
      Adapt xcb/util libraries for removal of XID structures.

Jamey Sharp (8):
      Update .gitignores for .o files and autofoo stuff.
      Unify autofoo .gitignore bits into one top-level file, and remove resulting redundancies.
      libxcb now installs header files in <xcb>, not <X11/XCB>.
      Bug #6781: make util compile with srcdir != builddir.
      Release xcb-util 0.2
      All util libraries require the XCB 1.0 API; check for it in configure.
      icccm does not depend on xcb-proto, only generated headers in xcb.
      Delete callback-based APIs for events, properties, and replies.

Jon TURNEY (2):
      Update autogen.sh to one that does builddir != srcdir
      Link with -no-undefined

Jonathan Landis (1):
      Fix copyright statement

Josh Triplett (5):
      Remove xcl and CVSROOT.
      Fix xcb-util library dependencies, including both the new dependency libXCBImage needs on libXCBShm, as well as many other issues discovered in the process.  These include using automake variables appropriately in order to actually link shared libraries against each other and ensure libraries have NEEDED entries for the libraries they depend on, consequently needing to reorder the top-level SUBDIRS to build property before icccm, adding dependencies to .pc.in files, fixing .pc.in files to not all use the name and description for XCBImage, and adding appropriate library dependencies to test programs.
      Set all package bugreporting addresses to xcb@lists.freedesktop.org
      xcb-icccm doesn't use xcb-event; it just needs the headers due to xcb-property, and can't use the xcb-property pkg-config file from within the same source tree to pull it in.
      Integrate top-level .gitignore into .gitignore for each subdirectory

Julien Danjou (27):
      icccm: add xcb_get_wm_transient_for()
      icccm: add urgency hint functions
      prepare 0.2.1 release
      icccm: fix memory leak in xcb_get_wm_hints()
      icccm: fix wrong variable initialization
      icccm: free reply in wm hints retrieval
      icccm: allow information retrieval from reply
      doc: add various authors, remove old todo item
      doc: enable doxygen doc in various submodule
      icccm: introduce xcb_get_wm_transient_for_from_reply
      icccm: add some comment on text reply usage
      icccm: fix normal hints flags computing
      configure: stop if m4 is not found
      Release xcb-util 0.3.1
      build: add check for xproto >= 7.0.8
      icccm: fix gravity proto
      Release xcb-util 0.3.2
      icccm: change class hint struct fields name
      Release xcb-util 0.3.3
      icccm: add xcb_get_wm_class_from_reply()
      bump version to 0.3.4
      icccm: fix compatibility with libxcb > 1.2
      Release xcb-util 0.3.5
      icccm: fix atoms_len with new libxcb
      icccm: typo fix
      icccm: add xcb_get_wm_protocols_from_reply
      icccm: fix reply->format check

Mikhail Gusarov (1):
      Typo in configure.ac

Peter Harris (3):
      Fix the type of 'input' in icccm/xcb_icccm.h/xcb_wm_hints_t
      Validate size of wm_hints and wm_size_hints
      Ensure get_wm_class_from_reply returns a valid C-string

TORRI Vincent (10):
      fix some warnings
      fix compilation with c++ compilers. Remove some trailing spaces
      add AllocWMHints and SetWMHints functions. Remove trailing spaces. Fix an indentation
      add GetWMIconName and WM_CLIENT_MACHINE functions
      typo
      it's also probably a good idea to update the header file...
      rename the libraries from libXCBFoo.* to libxcb-foo.*. Use foo_CPPFLAGS instead of foo_CFLAGS (*_CFLAGS variables store preprocessor options)
      event/events.c
      missing namespace for alloc_wm_hints in xcb_icccm.h
      add _checked version of the _set_ functions

Thomas Hunger (1):
      icccm: new naming convention

Uli Schlachter (3):
      _NET_WM_ICON: Fix the length check
      xcb_ewmh_get_wm_icon_reply: Fix crash on error
      Return more icons from _NET_WM_ICON


Reply to: