[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#612983: xserver-xorg: X does not start

On Sat, Feb 12, 2011 at 09:22:24AM +0100, Cyril Brulebois wrote:
   > Sridhar M.A. <mas@mylug.org> (12/02/2011):
   > > Since yesterday morning, X does not start on my Acer laptop which
   > > has an intel card (laptop is acer 5745). I tried installing the
   > > xserver packages from unstable with the same result. Rolled back to
   > > testing and X still does not start. I removed /etc/X11/xorg.conf and
   > > tried without success.
   > I might be lacking coffee, but the log looks fine. How do you start X?
   > Through GDM/KDM/something? What is the last known working situation?
   > Before you upgraded yesterday morning? What else did you upgrade?
Sorry for sending the message multiple times. The mailer log kept
showed that the mail was rejected and hence I tried a couple of times.

Coming back to the problem, I now found some workarounds and starnge
behaviour (to me). 

As mentioned, X would not start. Disabled gdm3 and tried from startx.
No success. Not only that, I cannot use the machine, as keyboard is also
locked up. But, I can ssh into it. Removed gdm3 and tried startx. X
works! Gnome is working fine.

But, many a time I use openbox. So, set it in ~/.xinitrc and tried
startx. X carshed with the following error in ~/.xsession-errors :
 How are you gentlemen all your base OS belong to us ....
(Maybe not the exact wording, but to that effect; I am sending this from
my desktop).

Installed gdm. X comes up without any problem. Again, gnome works fine,
openbox as before crashes.

Right now, gdm+gnome works for me. gdm3 does not even allow X to start


Sridhar M.A.                                 GPG KeyID : F6A35935
  Fingerprint: D172 22C4 7CDC D9CD 62B5  55C1 2A69 D5D8 F6A3 5935

"The road to hell is paved with melting snowballs."
		-- Larry Wall in  <1992Jul2.222039.26476@netlabs.com>

Attachment: signature.asc
Description: Digital signature

Reply to: