[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#546836: Bug confirmed: Matrox G550 unusable under squeeze

On Mit, 2011-01-26 at 00:45 +0100, Etienne Vogt wrote: 
> On Tue, 25 Jan 2011, Cyril Brulebois wrote:
> > could you please check whether there's something in Xorg.0.log.old?
> > Maybe the one with no info is a restarted one?
> No, it ends up with :
> drmOpenByBusid: Searching for BusID pci:0000:01:00.0
> drmOpenDevice: node name is /dev/dri/card0
> drmOpenDevice: open result is 14, (OK)
> drmOpenByBusid: drmOpenMinor returns 14
> drmOpenByBusid: Interface 1.4 failed, trying 1.1
> drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
> (II) AIGLX: enabled GLX_SGI_make_current_read
> (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
> (II) AIGLX: Loaded and initialized /usr/lib/dri/mga_dri.so
> (II) GLX: Initialized DRI GL provider for screen 0

If the X log file ends abruptly like that, there's usually more
information in the X server stderr output, which should be captured in
the gdm/kdm/... log file.

> Anyways, I did some test with the Matrox G550 card in another system
> also in squeeze and it worked fine in that system, with the
> same xorg.conf and the same kernel. 
> I then plugged the card back in the affected system but swapped the
> harddisks, and it also worked fine.
> Finally, I put the original hard disk back in, upgraded Xorg again
> to the squeeze version and the problem reappeared :-(
> So, I have something on that disk that is causing trouble. I already
> know it's not xorg.conf nor the kernel. And I have the same set of
> xserver-* packages on the two systems.

Symptoms such as above are often caused by stale libraries in /usr/local
or so, resulting in unresolved symbols.

Earthling Michel Dänzer           |                http://www.vmware.com
Libre software enthusiast         |          Debian, X and DRI developer

Reply to: