[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems to build a debianlive with SID using encryption



Hello all:

I'm trying to build a debianlive image using SID. I want to use encryption, so the configuration I have used is the following one:

*lh_config -b usb-hdd --username smith --hostname estasia -p gnome-desktop --bootappend-live "keyb=es locale=es_ES.UTF-8 vga=792 splash quiet" --debian-installer live -e aes192 -a i386 -d sid

*I used the same configuration previously in order to create an image with lenny, and it works perfectly.

I execute *lh bootstrap* and it works, but when I execute *lh chroot* I got the following error:

Del libxml-twig-perl 1:3.32-3 [177kB]
P: Begin queueing installation of packages lists...
P: Begin queueing installation of local packages lists...
P: Begin queueing installation of packages...
P: Begin queueing installation of local packages...
P: Begin installing packages...
Reading package lists... Done
Building dependency tree Reading state information... Done
E: Couldn't find package loop-aes-modules-2.6-486


My chroot configuration file is the following one:

# config/chroot - options for live-helper(7), chroot stage

# $LH_CHROOT_FILESYSTEM: set chroot filesystem
# (Default: squashfs)
LH_CHROOT_FILESYSTEM="squashfs"

# $LH_UNION_FILESYSTEM: set union filesystem
# (Default: aufs)
LH_UNION_FILESYSTEM="aufs"

# $LH_VIRTUAL_ROOT_SIZE: set virtual-hdd filesystem size
# (Default: 10000)
LH_VIRTUAL_ROOT_SIZE="10000"

# $LH_EXPOSED_ROOT: expose root as read only
# (Default: false)
LH_EXPOSED_ROOT="false"

# $LH_HOOKS: set hook commands
# (Default: empty)
LH_HOOKS=""

# $LH_INTERACTIVE: set interactive build
# (Default: false)
LH_INTERACTIVE="false"

# $LH_KEYRING_PACKAGES: set keyring packages
# (Default: empty)
LH_KEYRING_PACKAGES="debian-archive-keyring"

# $LH_LANGUAGE: set language to use
# (Default: empty)
LH_LANGUAGE="en"

# $LH_LINUX_FLAVOURS: set kernel flavour to use
# (Default: autodetected)
LH_LINUX_FLAVOURS="486 686"

# $LH_LINUX_PACKAGES: set kernel packages to use
# (Default: autodetected)
LH_LINUX_PACKAGES="linux-image-2.6 loop-aes-modules-2.6"

# $LH_PACKAGES: set packages to install
# (Default: empty)
LH_PACKAGES="less usbmount autofs firmware-iwlwifi splashy splashy-themes iceweasel iceweasel-l10n-es-es mozilla-plugin-vlc icedove iceowl-extension xmame-x xmame-tools xmame-svga xmame-sdl xmame-gl xmame-common vlc icedove icedove-gnome-support iceowl-extension icedove-locale-es-es icedove-l10n-es-es"


# $LH_PACKAGES_LISTS: set package list to install
# (Default: standard-x11)
LH_PACKAGES_LISTS="standard-x11"

# $LH_TASKS: set tasks to install
# (Default: empty)
LH_TASKS="standard gnome-desktop desktop"

# $LH_SECURITY: enable security updates
# (Default: true)
LH_SECURITY="true"

# $LH_SYMLINKS: enable symlink convertion
# (Default: false)
LH_SYMLINKS="false"

# $LH_SYSVINIT: enable sysvinit
# (Default: false)
LH_SYSVINIT="false"



I have tried to look for information on the internet, but I couldn't find anything. I hope you can help me or give me some clue.

Thank you very much


Reply to: