[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#558786: X.org radeon driver breaks KDE when radeon.ko is present



Hi,

this actually has a deeper impact.

DRI1 is used by the radeon X.org driver when radeon.modeset=0 (linux-2.6.32) but then KDE is horribly broken (scrolling in any KDE application gives render errors). Forcing XAA doesn't work (EXA is always used). This is only solved by preventing radeon.ko from being loaded. This issue is also present in linux-2.6.31.

DRI2 is tried by the radeon X.org driver when radeon.modeset=1 (which works great on the VT). But since libdrm doesn't support that in unstable, it breaks X completely (KDM doesn't show any useful screen, all garbled).

I didn't test compiling libdrm and mesa myself (didn't want to mess with my system). Thus, any DRI is currently impossible on my Radeon Mobility HD 2400 XT (RV610 / M7[24]). However, not using radeon.ko and thus only 2D works fine :)

I would really like to test libdrm-radeon, too.

HS





Reply to: