[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#555647: x11-xserver-utils: xrandr -o left leaves xdm, after I logout, unresponsive, with no login prompt

Package: x11-xserver-utils
Version: 7.4+2
Severity: normal

I use xrandr -o left in my .xsession so that I can use my screen in
portrait mode.  However, after a recent upgrade, I find that when I
log out (exit fvwm) I don't get the xdm login prompt I'm expecting.
I have to restart xdm.

Previously, when I logged out, xdm's login prompt was correctly
oriented for the portrait mode in which I was using the screen - which
was potentially an issue, since a feature of my session survived to
affect whoever might log in after me.  However, this worked nicely for
me; in particular, it facilitated a work-around for a problem with the
fonts used in portrait mode, the first time I logged in; logging out
and back in fixed it.  I can no longer do that.

Tell me what I need to log to help diagnose the problem ...

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.30-2-686 (SMP w/2 CPU cores)
Locale: LANG=en_GB.ISO-8859-15, LC_CTYPE=en_GB.ISO-8859-15 (charmap=ISO-8859-15)
Shell: /bin/sh linked to /bin/bash

Versions of packages x11-xserver-utils depends on:
ii  cpp                       4:4.3.3-9+nmu1 The GNU C preprocessor (cpp)
ii  libc6                     2.10.1-5       GNU C Library: Shared libraries
ii  libice6                   2:1.0.5-1      X11 Inter-Client Exchange library
ii  libsm6                    2:1.1.1-1      X11 Session Management library
ii  libx11-6                  2:1.2.2-1      X11 client-side library
ii  libxau6                   1:1.0.5-1      X11 authorisation library
ii  libxaw7                   2:1.0.6-1      X11 Athena Widget library
ii  libxext6                  2:1.0.4-1      X11 miscellaneous extension librar
ii  libxi6                    2:1.2.1-2      X11 Input extension library
ii  libxmu6                   2:1.0.4-2      X11 miscellaneous utility library
ii  libxmuu1                  2:1.0.4-2      X11 miscellaneous micro-utility li
ii  libxrandr2                2:1.3.0-2      X11 RandR extension library
ii  libxrender1               1:0.9.4-2      X Rendering Extension client libra
ii  libxt6                    1:1.0.6-1      X11 toolkit intrinsics library
ii  libxtrap6                 2:1.0.0-5      X11 event trapping extension libra
ii  libxxf86misc1             1:1.0.1-3      X11 XFree86 miscellaneous extensio
ii  libxxf86vm1               1:1.0.2-1      X11 XFree86 video mode extension l
ii  x11-common                1:7.4+4        X Window System (X.Org) infrastruc

x11-xserver-utils recommends no packages.

Versions of packages x11-xserver-utils suggests:
pn  cairo-5c                      <none>     (no description available)
pn  nickle                        <none>     (no description available)

-- no debconf information

Reply to: