[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#496038: marked as done (stellarium: segmentation fault)

Your message dated Fri, 6 Nov 2009 18:42:23 +0100
with message-id <20091106174223.GT4499@patate.is-a-geek.org>
and subject line Re: Bug#496038: stellarium: segmentation fault
has caused the Debian Bug report #496038,
regarding stellarium: segmentation fault
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

496038: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=496038
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: stellarium
Version: 0.9.1-4
Severity: normal

stellarium seg faults:
gdb stellarium                                                                                                                               
GNU gdb 6.8-debian                                                                                                                                            
Copyright (C) 2008 Free Software Foundation, Inc.                                                                                                             
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>                                                                                 
This is free software: you are free to change and redistribute it.                                                                                            
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"                                                                                    
and "show warranty" for details.                                                                                                                              
This GDB was configured as "x86_64-linux-gnu"...                                                                                                              
(no debugging symbols found)                                                                                                                                  
(gdb) run stellarium                                                                                                                                          
Starting program: /usr/bin/stellarium stellarium                                                                                                              
(no debugging symbols found)                                                                                                                                  
[Thread debugging using libthread_db enabled]                                                                                                                 
(no debugging symbols found)                                                                                                                                  
(no debugging symbols found)                                                                                                                                  
[New Thread 0x7f2c13efa780 (LWP 9321)]                                                                                                                        
(no debugging symbols found)                                                                                                                                  
(no debugging symbols found)                                                                                                                                  
Warning, xpress200 detected.                                                                                                                                  
[ This is Stellarium 0.9.1 - http://www.stellarium.org ]                                                                                                      
[ Copyright (C) 2000-2008 Fabien Chereau et al         ]                                                                                                      
File search paths:                                                                                                                                            
 0. /home/klaus/.stellarium                                                                                                                                  
 1. /usr/share/stellarium                                                                                                                                     
Config file is: /home/klaus/.stellarium/config.ini                                                                                                           
(no debugging symbols found)
Sky language is nb
Application language is nb
Warning can't find module called  "StelUI" .
Loading Solar System data...(loaded)
Loading star data...

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f2c13efa780 (LWP 9321)]
0x00007f2c094f61f9 in ?? () from /usr/lib/dri/r300_dri.so
(gdb) bt
#0  0x00007f2c094f61f9 in ?? () from /usr/lib/dri/r300_dri.so
#1  0x00007f2c0961e517 in _mesa_PopAttrib () from /usr/lib/dri/r300_dri.so
#2  0x0000000000479360 in Projector::drawText ()
#3  0x000000000051111a in LoadingBar::Draw ()
#4  0x00000000004a767b in BigStarCatalogExtension::SpecialZoneArray<BigStarCatalogExtension::Star1>::SpecialZoneArray ()
#5  0x00000000004a4615 in BigStarCatalogExtension::ZoneArray::create ()
#6  0x00000000004adc62 in StarMgr::load_data ()
#7  0x00000000004b0847 in StarMgr::init ()
#8  0x000000000054b6df in StelApp::init ()
#9  0x000000000061635b in StelAppQt4::startMainLoop ()
#10 0x000000000061683b in StelAppQt4::runStellarium ()
#11 0x000000000065cdee in main ()

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=nb_NO.UTF-8, LC_CTYPE=nb_NO.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages stellarium depends on:
ii  libc6                  2.7-13            GNU C Library: Shared libraries
ii  libfreetype6           2.3.7-1           FreeType 2 font engine, shared lib
ii  libgcc1                1:4.3.1-2         GCC support library
ii  libgl1-mesa-glx [libgl 7.0.3-5           A free implementation of the OpenG
ii  libglu1-mesa [libglu1] 7.0.3-5           The OpenGL utility library (GLU)
ii  libice6                2:1.0.4-1         X11 Inter-Client Exchange library
ii  libjpeg62              6b-14             The Independent JPEG Group's JPEG 
ii  libpng12-0             1.2.27-1          PNG library - runtime
ii  libqt4-network         4.4.1-1           Qt 4 network module
ii  libqt4-opengl          4.4.1-1           Qt 4 OpenGL module
ii  libqt4-script          4.4.1-1           Qt 4 script module
ii  libqtcore4             4.4.1-1           Qt 4 core module
ii  libqtgui4              4.4.1-1           Qt 4 GUI module
ii  libsdl-mixer1.2        1.2.8-4           mixer library for Simple DirectMed
ii  libsm6                 2:1.0.3-2         X11 Session Management library
ii  libstdc++6             4.3.1-2           The GNU Standard C++ Library v3
ii  libx11-6               2:1.1.4-2         X11 client-side library
ii  libxext6               2:1.0.4-1         X11 miscellaneous extension librar
ii  stellarium-data        0.9.1-4           datafiles for Stellarium, a real-t
ii  zlib1g                 1: compression library - runtime

stellarium recommends no packages.

stellarium suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
On Wed, Feb 18, 2009 at 21:52:20 +0100, Brice Goglin wrote:

> Debian Bug Tracking System wrote:
> > Bug#496038: stellarium: segmentation fault
> > Bug reassigned from package `stellarium' to `libgl1-mesa-dri'.
> >   
> Klaus,
> Please install libgl1-mesa-dri-dbg and catch a debugging backtrace with
> gdb again. Make sure you enter 'bt full' in gdb.
> thanks,
> Brice
No reply since february, closing.


--- End Message ---

Reply to: