[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#490573: marked as done ([xserver-xorg-video-intel] No video into projector)

Your message dated Mon, 15 Jun 2009 16:20:30 +0200
with message-id <4A3658AE.2000807@ens-lyon.org>
and subject line Re: Solved in principle ([xserver-xorg-video-intel] No video into 	projector)
has caused the Debian Bug report #490573,
regarding [xserver-xorg-video-intel] No video into projector
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

490573: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=490573
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message --- Package: xserver-xorg-video-intel
Version: 2:2.3.2-2
Severity: important

--- Please enter the report below this line. ---


I am afraid I cannot give much information, because it happened to me some weeks ago with a projector whose brand I do not know. On Monday I have to give another presentation which embedded videos, so *it is not portable to the computer they will have there with Windows*. OK, I could have asked Brice independently :-) instead of submitting a bug, but I am submitting the bug just in case it is a real bug and not my fault. If it is not a real bug, please forgive me and close the bug.

I use Debian sid with KDE, and the display is "Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)".

When I plugged the projector and rebooted, the GRUB and boot video output was directed to the projector, but as soon as kdm started the video output was in the computer screen and not in the projector. Pressing Fn + F5  did nothing.

Sorry if it is my fault and not a bug, and hope it helps in case it is a bug.

Thank you,


--- System information. ---
Architecture: i386
Kernel: Linux 2.6.25-2-686

Debian Release: lenny/sid
990 unstable www.debian-multimedia.org
990 unstable ftp.uk.debian.org
500 testing dl.google.com
500 stable dl.google.com
500 experimental www.debian-multimedia.org
1 experimental ftp.uk.debian.org

--- Package information. ---
Depends (Version) | Installed
libc6 (>= 2.7-1) | 2.7-12
libdrm2 (>= 2.3.0) | 2.3.0-4
xserver-xorg-core (>= 2:1.4) | 2:1.4.2-1

--- End Message ---
--- Begin Message ---
Version: 2:2.7.1-1

David wrote:
> Hello again,
> Well, it worked last time I tried it, at least in this situation:
> 1) The projector's jack was plugged into my computer before booting
> the latter.
> 2) The KDE4 desktop effects (composition) were disabled.
> After booting the computer and the x-server was initialized, both the
> computer's screen and the video projector were showing the same video.

Ok, I marking the bug as fixed in 2.7.1 then.

> Although the screen of my laptop is wide, the dimensions had been
> adjusted to match the ones of the projector, by means of vertical
> black stripes at both sides of the laptop's screen (which persisted
> after unplugging the projector, I had to reboot to get the full screen).

When you boot with a projector plugged, the W server tries to find a
mode that's supported by both the projector and the internal laptop
panel. So it probably finds a 4/3 mode while the panel is 16/10. In this
case, by default, the intel driver keeps the display ratio and uses
black stripes on the sides (and it should be configurable with xrandr
properties, no need to reboot).


--- End Message ---

Reply to: