[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#482727: marked as done (libdrm: FTBFS when converted to new source format 3.0 (quilt))

Your message dated Tue, 24 Mar 2009 21:47:04 +0000
with message-id <E1LmESe-0000vI-Q5@ries.debian.org>
and subject line Bug#482727: fixed in libdrm 2.4.5-1
has caused the Debian Bug report #482727,
regarding libdrm: FTBFS when converted to new source format 3.0 (quilt)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

482727: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=482727
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: libdrm
Version: 2.3.0-4
Severity: minor
Usertags: 3.0-quilt-by-default

To prepare a possible switch to the new source package format "3.0
(quilt)" [1], I converted all source packages and rebuilt the packages
afterwards to see what breaks, and libdrm does break. To reproduce the
problem you can do this:

$ apt-get source libdrm
$ sed -i -e '/^Source:/ aFormat: 3.0 (quilt)' libdrm-2.3.0/debian/control
$ dpkg-source -b libdrm-2.3.0
$ dpkg-source -x libdrm_2.3.0-4.dsc
$ cd libdrm-2.3.0 && debuild -us -uc

In this process, if the .diff.gz contains changes to upstream files,
dpkg-source will have created a corresponding patch in
debian/patches/debian-changes-2.3.0-4 and will have registered that
patch in a quilt series (debian/patches/series, it is created if needed).
All the patches listed in the "series" file are applied directly during
the extraction (dpkg-source -x). quilt itself is used if available (and
will thus lead to the creation of the .pc directory), otherwise
dpkg-source applies the patches by itself. For more information about the
new source package format see the manual page dpkg-source(1).

In the case of libdrm, the .diff.gz contains changes to
config.sub/guess because your "clean" target in debian/rules replaces
those files. With the conversion to the new source format, those
changes end up as a patch in debian/patches/ and when the package
tries to apply that patch it will fail because the clean rule has already
replaced those files.

To fix this, please make sure that the .diff.gz doesn't contain those
changes. You can easily do that by copying
/usr/share/misc/config.{sub,guess} in place just before the ./configure
call and by removing (rm -f config.sug config.guess) the files
in the clean target. (I just filed #482716 against autotools-dev so that
/usr/share/doc/autotools-dev/README.Debian.gz is updated in that regard)


[1] http://lists.debian.org/debian-devel-announce/2008/04/msg00004.html
Raphael Hertzog

--- End Message ---
--- Begin Message ---
Source: libdrm
Source-Version: 2.4.5-1

We believe that the bug you reported is fixed in the latest version of
libdrm, which is due to be installed in the Debian FTP archive:

  to pool/main/libd/libdrm/libdrm-dev_2.4.5-1_amd64.deb
  to pool/main/libd/libdrm/libdrm-intel1-dbg_2.4.5-1_amd64.deb
  to pool/main/libd/libdrm/libdrm-intel1_2.4.5-1_amd64.deb
  to pool/main/libd/libdrm/libdrm2-dbg_2.4.5-1_amd64.deb
  to pool/main/libd/libdrm/libdrm2_2.4.5-1_amd64.deb
  to pool/main/libd/libdrm/libdrm_2.4.5-1.diff.gz
  to pool/main/libd/libdrm/libdrm_2.4.5-1.dsc
  to pool/main/libd/libdrm/libdrm_2.4.5.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 482727@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Julien Cristau <jcristau@debian.org> (supplier of updated libdrm package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Tue, 24 Mar 2009 22:20:50 +0100
Source: libdrm
Binary: libdrm-dev libdrm2 libdrm2-dbg libdrm-intel1 libdrm-intel1-dbg
Architecture: source amd64
Version: 2.4.5-1
Distribution: unstable
Urgency: low
Maintainer: Debian X Strike Force <debian-x@lists.debian.org>
Changed-By: Julien Cristau <jcristau@debian.org>
 libdrm-dev - Userspace interface to kernel DRM services -- development files
 libdrm-intel1 - Userspace interface to intel-specific kernel DRM services -- runt
 libdrm-intel1-dbg - Userspace interface to intel-specific kernel DRM services -- debu
 libdrm2    - Userspace interface to kernel DRM services -- runtime
 libdrm2-dbg - Userspace interface to kernel DRM services -- debugging symbols
Closes: 482727 502078 505740
 libdrm (2.4.5-1) unstable; urgency=low
   * New upstream release. (closes: #505740)
   [ Timo Aaltonen ]
   * debian/rules:
     -Run autoreconf at build time, build-depend on automake and libtool.
      (closes: #482727)
     -Add a debian/libdrm2.symbols file and '-c4' parameter to dh_makeshlibs
      to fail if new symbols are added. Don't use Debian versions for now.
   [ Julien Cristau ]
   * Add a new package for the intel-specific bits (libdrm-intel1)
   * Build-depend on pkg-config and libpthread-stubs0-dev (closes: #502078).
     Thanks, Frank Lichtenheld!
   * Don't mention *.la in libdrm-dev.install.
   * Make libdrm-dev depend on libdrm-intel1 on x86.
   * On Linux, let udev create the device files.
   * Let linux-libc-dev provide some drm headers, drop them from libdrm-dev.
     Add dependency on linux-libc-dev >= 2.6.28.
   * Set libdrm2 shlibs to 2.4.3, libdrm-intel1 shlibs to 2.4.5.  Update
     symbols files.
 7472ed026c87a9696a617d31069fc83cea395ac0 1361 libdrm_2.4.5-1.dsc
 9e919c4cda6454118ebd288edc3bc65fc6779a51 563395 libdrm_2.4.5.orig.tar.gz
 bdc0f7c109676afcd2188db9537a3a1a6361f6db 374126 libdrm_2.4.5-1.diff.gz
 c66ac5026b8c9fdd499169ad93adb96dcd0850d9 441432 libdrm-dev_2.4.5-1_amd64.deb
 c8890be1793350815119d98b5c0de3c319e25779 376960 libdrm2_2.4.5-1_amd64.deb
 badd283b21af6b3d0ffaa1aa6874adac628e9808 392006 libdrm2-dbg_2.4.5-1_amd64.deb
 6ab74a0bb9829a309bdc82932652fef3894a497b 375168 libdrm-intel1_2.4.5-1_amd64.deb
 d366e7877ed946e33047ed3c828537831dfb4c84 386542 libdrm-intel1-dbg_2.4.5-1_amd64.deb
 48b94e177bd86f8b8a5bf4043e4a7a92a77968b4116259e001ef90741ce6f7c8 1361 libdrm_2.4.5-1.dsc
 4ada5afa0ac774b9affce9762e703d0a98bfcb3537a5230ef12955b0068259d1 563395 libdrm_2.4.5.orig.tar.gz
 bbb545d6f7a7b0853e8297ee6001b7b64697da6b5ff64aee1abc23d42ecefc59 374126 libdrm_2.4.5-1.diff.gz
 703fff0b6d9873f7da974de8ff808f367931eb871803b6cfb1938aae17df1d3f 441432 libdrm-dev_2.4.5-1_amd64.deb
 66a3d06fcbfc6db5aac0d47e9a602b30db9fdf684274085fa327035f07c5ff71 376960 libdrm2_2.4.5-1_amd64.deb
 d69195ede0e725a311e5afb01bd33f9d004e98edfae3abbcf8d7da2125fa4049 392006 libdrm2-dbg_2.4.5-1_amd64.deb
 afca51abf8d15c8b5619d020ff2f22eb2f79f51e022cb8c8c4bc3c4bbe297b66 375168 libdrm-intel1_2.4.5-1_amd64.deb
 e597a153ef3777e2d4ecf942c90fd72de0404709aaa08c23d3e7a9bf13cdfde8 386542 libdrm-intel1-dbg_2.4.5-1_amd64.deb
 67bad3b7220c2206be0db68a1f0577e3 1361 libs optional libdrm_2.4.5-1.dsc
 4d86f50bab4f36d5a3c63f20086736a5 563395 libs optional libdrm_2.4.5.orig.tar.gz
 5b63a6289ac1a9fff4050a4aace08d4d 374126 libs optional libdrm_2.4.5-1.diff.gz
 2402a15efec10d2334d932f5900f13a6 441432 libdevel optional libdrm-dev_2.4.5-1_amd64.deb
 275b1282580ba651190f8f8a24602bd2 376960 libs optional libdrm2_2.4.5-1_amd64.deb
 e698f75c41c5cd61db4d9a9f735bcd20 392006 libdevel extra libdrm2-dbg_2.4.5-1_amd64.deb
 90b48da07c9e2bacbdf515fff8e898a4 375168 libs optional libdrm-intel1_2.4.5-1_amd64.deb
 35913971b38b65047c1fc67126bec024 386542 libdevel extra libdrm-intel1-dbg_2.4.5-1_amd64.deb

Version: GnuPG v1.4.9 (GNU/Linux)


--- End Message ---

Reply to: