[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#520167: marked as done ([xserver-xorg-video-radeonhd] icons are garbled)

Your message dated Tue, 17 Mar 2009 23:02:21 +0100
with message-id <49C01DED.8040207@ens-lyon.org>
and subject line Re: Bug#520167: [xserver-xorg-video-radeonhd] icons are garbled
has caused the Debian Bug report #520167,
regarding [xserver-xorg-video-radeonhd] icons are garbled
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

520167: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=520167
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: xserver-xorg-video-radeonhd
Severity: normal

--- Please enter the report below this line. ---
Since the current version, many icons in KDE 3.x and GTK applications are 
garbled. Usually the lower part looks broken, as if some gibberish data was 

--- System information. ---
Architecture: i386
Kernel:       Linux 2.6.28-1-686-bigmem

Debian Release: squeeze/sid
  500 unstable        www.debian-multimedia.org 
  500 unstable        ftp.de.debian.org 
  500 testing         ftp.de.debian.org 
  500 oldstable       security.debian.org 
    1 experimental    ftp.de.debian.org 

--- Package information. ---
Depends                (Version) | Installed
libc6                 (>= 2.7-1) | 2.9-4
libpci3                          | 1:3.1.2-1
xserver-xorg-core     (>= 2:1.4) | 2:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg
# The following is advice from http://wiki.ubuntuusers.de/ATI-Grafikkarten/fglrx?
# gis.

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "aticonfig-Screen[0]" 0 0
	InputDevice    "Generic Keyboard"
	InputDevice    "Configured Mouse"
	InputDevice    "Synaptics Touchpad"

Section "Files"

	# path to defoma fonts
	FontPath     "/usr/share/fonts/X11/misc"
	FontPath     "/usr/X11R6/lib/X11/fonts/misc"
	FontPath     "/usr/share/fonts/X11/cyrillic"
	FontPath     "/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/Type1"
	FontPath     "/usr/X11R6/lib/X11/fonts/Type1"
	FontPath     "/usr/share/fonts/X11/100dpi"
	FontPath     "/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath     "/usr/share/fonts/X11/75dpi"
	FontPath     "/usr/X11R6/lib/X11/fonts/75dpi"
	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

Section "Module"
	Load  "bitmap"
	Load  "ddc"
	Load  "dri"
	Load  "extmod"
	Load  "freetype"
	Load  "glx"
	Load  "int10"
	Load  "vbe"
	Load  "record"

Section "ServerFlags"
#	Option	    "AIGLX" "off"

Section "InputDevice"
	Identifier  "Generic Keyboard"
	Driver      "kbd"
	Option	    "CoreKeyboard"
	Option	    "XkbRules" "xorg"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "de"
#	Option	    "XkbVariant" "nodeadkeys"

Section "InputDevice"
	Identifier  "Configured Mouse"
	Driver      "mouse"
	Option	    "CorePointer"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "ImPS/2"

Section "InputDevice"
	Identifier  "Synaptics Touchpad"
	Driver      "synaptics"
	Option	    "SendCoreEvents" "true"
	Option	    "Device" "/dev/psaux"
	Option	    "Protocol" "auto-dev"
	Option	    "HorizScrollDelta" "0"

Section "Monitor"
	Identifier   "Eizo Flexscan S2110W"
	HorizSync    30.0 - 90.0
	VertRefresh  50.0 - 60.0
	Option	    "DPMS"

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"

Section "Device"
	Identifier  "ATI Radeon Mobility X1400"
	Driver      "radeon"
#	Driver      "radeonhd"
	BusID       "PCI:1:0:0"
	Option      "AccelMethod"	"EXA"
	Option      "AccelDFS"		"true"

Section "Device"
	Identifier  "aticonfig-Device[0]"
	Driver      "fglrx"
	#Option	    "DesktopSetup" "horizontal"
	Option	    "DesktopSetup" "mirror"
#	Option	    "DesktopSetup" "single"
	# for Xvideo extension
#	Option      "VideoOverlay" "on"
#	Option       "OpenGLOverlay" "off"
#	Option       "TexturedVideo" "on"

Section "Screen"
	Identifier "Default Screen"
	Device     "ATI Radeon Mobility X1400"
	Monitor    "Eizo Flexscan S2110W"
	DefaultDepth     24
	SubSection "Display"
		Depth     1
		Modes    "1680x1050" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth     4
		Modes    "1680x1050" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth     8
		Modes    "1680x1050" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth     15
		Modes    "1680x1050" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth     16
		Modes    "1680x1050" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth     24
		Modes    "1680x1050" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
		Virtual  3360 1050

Section "Screen"
	Identifier "aticonfig-Screen[0]"
	Device     "ATI Radeon Mobility X1400"
#	Device     "aticonfig-Device[0]"
	Monitor    "aticonfig-Monitor[0]"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Virtual  3360 1050

Section "DRI"
	Mode         0666

Section "Extensions"
	Option	    "Composite" "Disable"

Attachment: signature.asc
Description: This is a digitally signed message part.

--- End Message ---
--- Begin Message ---
Carsten Pfeiffer wrote:
> Thanks for the quick reply, and for noticing my old xserver version.
> I downgrade to those from unstable:
> $ dpkg -l xserver-xorg-video-radeon* xserver-xorg-core xserver-xorg | grep ^ii
> ii  xserver-xorg                                             1:7.3+18                       
> the X.Org X server
> ii  xserver-xorg-core                                        2:1.4.2-11                     
> Xorg X server - core server
> ii  xserver-xorg-video-radeon                                1:6.9.0-1+lenny4               
> X.Org X server -- ATI Radeon display driver
> ii  xserver-xorg-video-radeonhd                              1.2.1-2                        
> X.Org X server -- AMD/ATI r5xx, r6xx display
> With my previous xorg.conf and using the radeon (not hd) driver, the icons 
> were still garbled. Removing my xorg.conf caused the radeonhd driver to be 
> used, and now the icons are all ok.

Good to know that radeonhd works fine, I am closing this bug then.

> Let me know if you want me to perform further tests with the radeon driver.

If your board is supposed to work with radeon 6.9.0, you might to open a
new bug report against radeon. Make sure your X config and log is attached


--- End Message ---

Reply to: