[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#518295: GL_LINE_LOOP not rendered correctly

reassign 518295 libgl1-mesa-dri 7.0.3-7
retitle 518295 GL_LINE_LOOP not rendered correctly on Radeon VE 7000 QY

> Package: libgl1-mesa-glx
> Version: 7.0.3-7
> After upgrading my home computer to Lenny I am observing a misbehavior of OpenGL programs, namely, whenever they should draw a GL_LINE_LOOP, the first and last segments of the line aren't drawn.
> I'm attaching a simple test program (compile with -lglut). The correct behavior would be to draw two nested white squares on a black background. Instead the outer square (drawn as a GL_LINE_STRIP with the start/end point repeated) is rendered correctly, but of the inner square (drawn as a GL_LINE_LOOP) only two segments are drawn.
> This problem seems to be specific of my hardware configuration, because I tried the same test program on another computer (with a Lenny live cd) and there it worked correctly. It is definitely a regression from Etch where it used to work also on my computer.
> My graphics card is rather old, it is a Radeon 7000. I'm using no proprietary drivers or nonstandard configurations, everything comes from the stock Lenny installation. I'm attaching the /var/log/Xorg.0.log file where I suppose you should find all the needed information. If you need more, please ask.

I can't reproduce this with a Radeon X300 (rv370) so this is indeed
probably a bug in the specific driver for your board (hence reassigning
to libgl1-mesa-dri). Now it would be nice to try with mesa 7.3
(currently in experimental).


Reply to: