[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#483699: video-nsc: PCI ID conflict with newer video-geode

Package: xserver-xorg-video-nsc
Version: 1:2.8.3-2
Severity: important

Because the upstream maintainers for the NSC drivers backported early
GX2 support from the old OLPC driver, there is a PCI ID conflict with
xserver-xorg-video-geode, which prevent Xorg -configure from operating
as expected, making LTSP fail to autoconfigure on hardware supported
by these drivers.

Three possible solutions that come to mind:

1) let the NSC driver attempt to manage GX2 hardware and hope for the best.

2) remove all known GX2 PCI ID from the nsc.ids and let
xserver-xorg-video-geode have them in geode.ids instead.

3) let it all rot until xserver-xorg-video-geode re-integrates support
for older Geode hardware, later this autumn, at which point the
transitional packages for the NSC and Cyrix drivers that will be
included in GEODE will fix it all magically.

Martin-Éric Racine

Reply to: