[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#483206: [xserver-xorg-video-intel] Xorg: screen gets blank randomly, and there is no way to recover

edwin wrote:
> Package: xserver-xorg-video-intel
> Version: 2:2.3.1-1
> Severity: normal
> --- Please enter the report below this line. ---
> I was writing an email in icedove, suddenly the screen went black
> (backlight still on).
> I switched to VTYs, and I could run commands, but switching back to X
> gave me a blank screen again. I tried typing, moving the mouse, with no
> results.
> I have started x11vnc from a terminal, and connected remotely, however
> all I got was a black screen.
> I also tried suspend-to-RAM, but it didn't bring me back the X console
> either (and neither did vbetool dpms off/on).
> I had to reboot (restarting just the X server didn't work either)
> I don't know how to debug this if it happens again. Any suggestions?
> Also, I never had such problems before upgrading to version 2.3.1 of the
> intel video driver.
> E.g. now sometimes when I login X is killed, and restarted, the 2nd
> login works fine. Unfortunately it is not always reproducible.
> I am running a 2.6.26-rc1 kernel, should that matter.

Can you try with latest upstream git? Some possibly related lockup were
fixed today (see https://bugs.freedesktop.org/show_bug.cgi?id=13326).

Some things that may somehow be related to such lockups: using EXA (i.e.
not having Option AccelMethod XAA), using multiple monitors at the same
time, having framebuffercompression enabled, ...

Please send the full output of <output> after running
"/usr/share/bug/xserver-xorg/script 3> output". And please do not use
reportbug-ng since it does not automatically include all required info
that we need to diagnose the problem.


Reply to: