[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#481275: xserver-xorg: xrandr works with RightOf but not LeftOf

Antony Gelberg wrote:
> Package: xserver-xorg
> Version: 1:7.3+10
> Severity: important
> Hi,
> As you can see, I specify Virtual 2960 1050 in my xorg config.  I have a
> 1680x1050 Philips monitor on the left, and a 1280x1024 Benq on the
> right.  The issues were:
> 1) xrandr reported:
> Screen 0: minimum 320 x 200, current 2560 x 1050, maximum 2960 x 1050
> i.e. current screen size < maximum by 400 pixels.
> 2) My right monitor worked well.  My left monitor was in the right 
> resolution, but the right, ooh let's say 400 pixels ;) was just a 
> replica of what was on my right monitor.
> This causes headaches as well as not giving me the screen I wanted.  
> I ran xrandr --fb 2960x1050, and xrandr then output:
> Screen 0: minimum 320 x 200, current 2960 x 1050, maximum 2960 x 1050,  
> but still what I was seeing on the screen was no better.
> In desperation, I changed LeftOf to RightOf, and it worked 
> perfectly (subject to me swapping the monitors round).  This is surely a 
> bug, as the user shouldn't have to guess a monitor order that might 
> work.
> I am not sure whether this is radeon-specific, and have no other 
> hardware to test with, hence I file against this package.

This may be similar to #466526, which has also been reported against the
radeon driver. Not sure what could be causing this kind of problem. We
should report this upstream at bugzilla.freedesktop.org.


Reply to: