[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#395159: marked as done (x11-common: [xsession] /etc/X11/Xsession.d contains obsolete XFree86 files (launches ssh-agent twice))

Your message dated Sun, 23 Mar 2008 15:18:49 +0100
with message-id <20080323141849.GA31652@loulous.org>
and subject line Re: Bug#318294: this bug/leaves /etc/X11/Xsession.d/*xfree86-common* files lying around
has caused the Debian Bug report #318294,
regarding x11-common: [xsession] /etc/X11/Xsession.d contains obsolete XFree86 files (launches ssh-agent twice)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

318294: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=318294
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: x11-common
Version: 1:7.1.0-5
Severity: normal

Xfree86 config files were left behind in /etc/X11/Xsession.d

As a result: they do not belong to any more packages; and ssh-agent is
launched twice (and various wrappers could have strange effects). Plus,
it is not elegant.

I do not know where is the right place to clean this mess (it should
have been made when the x11-* files were created).

Maybe simply deleting them, or sed'ing them so as to render them
inactive is the solution. But it will probably require to be post-etch.

As a workaround:
cd /etc/X11/Xsession.d
rm *xfree86*

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17-2-686
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)

Versions of packages x11-common depends on:
ii  debconf [debconf-2.0]         1.5.6      Debian configuration management sy
ii  debianutils                   2.17.3     Miscellaneous utilities specific t
ii  lsb-base                      3.1-17     Linux Standard Base 3.1 init scrip

x11-common recommends no packages.

-- debconf information:
* x11-common/xwrapper/allowed_users: Console Users Only
  x11-common/xwrapper/actual_allowed_users: console
* x11-common/upgrade_issues:
* x11-common/xwrapper/nice_value: -10

--- End Message ---
--- Begin Message ---
These files do not seem to be conffiles so it's not easy for us to remove
them only if they have not been modified. Also, I checked the upgrade from
sarge to etch followed by purging xfree86-common, all these files were
removed as expected.

There was probably a leak in some earlier packages and it's too late to fix
these sarge->etch upgrade. So I am just closing this bug, sorry guys.

Note to people reading this bug: you can safely remove all
the same functionality is provided by /etc/X11/Xsession.d/*x11*


--- End Message ---

Reply to: