[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#461889: closed by Brice Goglin <Brice.Goglin@ens-lyon.org> (Re: Bug#461889: xserver-xorg-core: broken dependencies)

Hi Brice!

Brice Goglin wrote:
Hi Bernhard,

There is no bug here.

Ahh, that's good to hear. I hope this means I can 'apt-get dist-upgrade' without having my xserver packages removed.

You had the xserver-xorg-input-wacom package
installed and it was preventing the upgrade from working properly.

Yes, the dependencies in the X packages are complex, but they are
needed to make sure people won't loose any package. They've been
discussed and improved a lot already (and may well get simplified
even more if the xserver-xorg package becomes completely useless).
All this works fine as long as you don't have any borderline package
such as wacom blocking things (it's not maintained by us, so it
may be outdated sometimes).

I don't care about the xserver-xorg-input-wacom package, since I don't have a tablet. But I can't get rid of it:

So, what do you recommend me to do? I tried ...

b:/etc/apt# apt-get update

b:~# apt-get remove xserver-xorg-input-wacom

Will remove all (or most of) my xserver packages.

b:~# dpkg -r xserver-xorg-input-wacom
xserver-xorg-input-all depends on xserver-xorg-input-wacom.

b:~# dpkg -r xserver-xorg-input-all
xserver-xorg depends on xserver-xorg-input-all | xserver-xorg-input; however:
  Package xserver-xorg-input-all is to be removed.
  Package xserver-xorg-input is not installed.

b:~# apt-get install xserver-xorg-input
Package xserver-xorg-input is a virtual package provided by:
  xserver-xorg-input-void 1:1.1.0-2
  xserver-xorg-input-vmmouse 12.4.0-2
  xserver-xorg-input-ur98 1:1.1.0-2
  xserver-xorg-input-tek4957 1:1.1.0-2
  xserver-xorg-input-summa 1:1.1.0-2
  xserver-xorg-input-spaceorb 1:1.1.0-2
  xserver-xorg-input-palmax 1:1.1.0-1
  xserver-xorg-input-mutouch 1:1.1.0-1
  xserver-xorg-input-magictouch 1:
  xserver-xorg-input-magellan 1:1.1.0-1
  xserver-xorg-input-jamstudio 1:1.1.0-1
  xserver-xorg-input-hyperpen 1:1.1.0-1
  xserver-xorg-input-fpit 1:1.1.0-1
  xserver-xorg-input-elographics 1:1.1.0-1
  xserver-xorg-input-digitaledge 1:1.1.0-1
  xserver-xorg-input-aiptek 1:1.0.1-3
  xserver-xorg-input-acecad 1:1.2.0-1
You should explicitly select one to install.

b:~# apt-get install xserver-xorg-input-void
xserver-xorg-input-void: Depends: xserver-xorg-core (>= 2:1.1.1) but it is not going to be installed

b:/etc/apt# apt-get install xserver-xorg-core
xserver-xorg-core: Depends: xserver-xorg but it is not going to be installed

b:/etc/apt# apt-get install xserver-xorg
xserver-xorg is already the newest version.

What do you recommend me to do? If there is no solition, I suggest to call it a bug.



Please encrypt all emails
GPG Key (ID F732FBF3 E4219D48) available on public key servers
and http://bksys.at/bernhard/E4219D48.pgp
Fingerprint E18F BF4D 0EE2 6522 E950  A06A F732 FBF3 E421 9D48

Reply to: