[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#456764: loading wacom breaks server (signal 11)



Package: xserver-xorg
Version: 1:7.3+8
Severity: serious

--- Please enter the report below this line. ---

Enabling loading the wacom core event devices in xorg.conf (by uncommenting the commented lines below) breaks loading of the X-server completely. With them commented out it works flawlessly.

apollo:~# tail /etc/X11/xorg.conf
Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
#	InputDevice	"stylus"	   "SendCoreEvents"
#	InputDevice	"eraser"	   "SendCoreEvents"
#	InputDevice    	"cursor"	   "SendCoreEvents"
#	InputDevice    	"pad"
EndSection

apollo:~# tail -30 /var/log/Xorg.1.log.old
(II) evaluating device (stylus)
(II) XINPUT: Adding extended input device "stylus" (type: Wacom Stylus)
(II) evaluating device (Configured Mouse)
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) evaluating device (Generic Keyboard)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
(**) Option "Device" "/dev/input/wacom"
pad Wacom X driver grabbed event device
(==) Wacom USB Graphire3 tablet speed=9600 maxX=10208 maxY=7424 maxZ=511 resX=2032 resY=2032 tilt=enabled
(==) Wacom device "pad" top X=0 top Y=0 bottom X=10208 bottom Y=7424
(==) Wacom device "cursor" top X=0 top Y=0 bottom X=10208 bottom Y=7424
(==) Wacom device "eraser" top X=0 top Y=0 bottom X=10208 bottom Y=7424
(==) Wacom device "stylus" top X=0 top Y=0 bottom X=10208 bottom Y=7424
(II) Configured Mouse: ps2EnableDataReporting: succeeded

Backtrace:
0: X(xf86SigHandler+0x7e) [0x80c660e]
1: [0xffffe420]
2: X(ProcXkbLatchLockState+0x23d) [0x8188b3d]
3: X [0x81891bd]
4: X [0x814d5fe]
5: X(Dispatch+0x2bf) [0x808d1bf]
6: X(main+0x48b) [0x807470b]
7: /lib/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7d08450]
8: X(FontFileCompleteXLFD+0x205) [0x8073a81]

Fatal server error:
Caught signal 11.  Server aborting

(II) SIS(0): Restoring by setting old mode 0x4a


--- System information. ---
Architecture: i386
Kernel:       Linux 2.6.22-3-686

Debian Release: lenny/sid
  990 unstable        honk.physik.uni-konstanz.de
  990 unstable        debian.ethz.ch
  300 experimental    debian.ethz.ch

--- Package information. ---
Depends                       (Version) | Installed
=======================================-+-=============
debconf                       (>= 0.5)  | 1.5.17
 OR debconf-2.0                         |
x11-xkb-utils                           | 7.3+1
xkb-data                                | 1.0~cvs.20070916-1
 OR xkb-data-legacy                     |
xserver-xorg-core          (>= 2:1.4-3) | 2:1.4.1~git20071212-1
xserver-xorg-input-all                  |
 OR xserver-xorg-input-2                |
xserver-xorg-video-all                  | 1:7.3+8
 OR xserver-xorg-video-2                |




Reply to: