[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#440095: marked as done (compiz should enable many plugins by default, at least decoration)



Your message dated Sun, 16 Dec 2007 17:32:03 +0000
with message-id <E1J3xLP-0006OK-AJ@ries.debian.org>
and subject line Bug#447345: fixed in compiz 0.6.3~git20071208.25941d14-1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: compiz
Version: 0.5.2-1
Severity: important


Hi,

when running compiz --replace (with metacity already managing the
windows), I get that:

GLX_EXT_texture_from_pixmap is not available with direct rendering.
GLX_EXT_texture_from_pixmap is available with indirect rendering.

then all decorations disappear, and that's all. I can't move the windows
(even when trying with ALT+drag), nothing works (ALT-tab,
ALT-CTRL-arrows, etc.). Exactely as if I had no window manager, except
compiz.real and gtk-window-decorator are running.

In fact, compiz.real is half-working because if I STOP it, the windows
stop updating (so the screen is effectively composited), but that's all.

	Xav

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (x86_64)

Kernel: Linux 2.6.22-1-amd64 (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages compiz depends on:
ii  compiz-core                   0.5.2-1    OpenGL window and compositing mana
ii  compiz-gnome                  0.5.2-1    OpenGL window and compositing mana
ii  compiz-gtk                    0.5.2-1    OpenGL window and compositing mana
ii  compiz-plugins                0.5.2-1    OpenGL window and compositing mana

compiz recommends no packages.

-- no debconf information



--- End Message ---
--- Begin Message ---
Source: compiz
Source-Version: 0.6.3~git20071208.25941d14-1

We believe that the bug you reported is fixed in the latest version of
compiz, which is due to be installed in the Debian FTP archive:

compiz-core_0.6.3~git20071208.25941d14-1_amd64.deb
  to pool/main/c/compiz/compiz-core_0.6.3~git20071208.25941d14-1_amd64.deb
compiz-dev_0.6.3~git20071208.25941d14-1_amd64.deb
  to pool/main/c/compiz/compiz-dev_0.6.3~git20071208.25941d14-1_amd64.deb
compiz-gnome_0.6.3~git20071208.25941d14-1_amd64.deb
  to pool/main/c/compiz/compiz-gnome_0.6.3~git20071208.25941d14-1_amd64.deb
compiz-gtk_0.6.3~git20071208.25941d14-1_amd64.deb
  to pool/main/c/compiz/compiz-gtk_0.6.3~git20071208.25941d14-1_amd64.deb
compiz-kde_0.6.3~git20071208.25941d14-1_amd64.deb
  to pool/main/c/compiz/compiz-kde_0.6.3~git20071208.25941d14-1_amd64.deb
compiz-plugins_0.6.3~git20071208.25941d14-1_amd64.deb
  to pool/main/c/compiz/compiz-plugins_0.6.3~git20071208.25941d14-1_amd64.deb
compiz_0.6.3~git20071208.25941d14-1.diff.gz
  to pool/main/c/compiz/compiz_0.6.3~git20071208.25941d14-1.diff.gz
compiz_0.6.3~git20071208.25941d14-1.dsc
  to pool/main/c/compiz/compiz_0.6.3~git20071208.25941d14-1.dsc
compiz_0.6.3~git20071208.25941d14-1_all.deb
  to pool/main/c/compiz/compiz_0.6.3~git20071208.25941d14-1_all.deb
compiz_0.6.3~git20071208.25941d14.orig.tar.gz
  to pool/main/c/compiz/compiz_0.6.3~git20071208.25941d14.orig.tar.gz
libdecoration0-dev_0.6.3~git20071208.25941d14-1_amd64.deb
  to pool/main/c/compiz/libdecoration0-dev_0.6.3~git20071208.25941d14-1_amd64.deb
libdecoration0_0.6.3~git20071208.25941d14-1_amd64.deb
  to pool/main/c/compiz/libdecoration0_0.6.3~git20071208.25941d14-1_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 447345@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Sean Finney <seanius@debian.org> (supplier of updated compiz package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 16 Dec 2007 17:29:03 +0100
Source: compiz
Binary: libdecoration0-dev compiz libdecoration0 compiz-core compiz-plugins compiz-gtk compiz-dev compiz-kde compiz-gnome
Architecture: source amd64 all
Version: 0.6.3~git20071208.25941d14-1
Distribution: unstable
Urgency: low
Maintainer: Debian X Strike Force <debian-x@lists.debian.org>
Changed-By: Sean Finney <seanius@debian.org>
Description: 
 compiz     - OpenGL window and compositing manager
 compiz-core - OpenGL window and compositing manager
 compiz-dev - OpenGL window and compositing manager - development files
 compiz-gnome - OpenGL window and compositing manager - GNOME window decorator
 compiz-gtk - OpenGL window and compositing manager - Gtk window decorator
 compiz-kde - OpenGL window and compositing manager - KDE window decorator
 compiz-plugins - OpenGL window and compositing manager - plugins
 libdecoration0 - Compiz window decoration library
 libdecoration0-dev - Compiz window decoration library - development files
Closes: 390929 393501 400583 440095 445026 446901 447345 449389
Changes: 
 compiz (0.6.3~git20071208.25941d14-1) unstable; urgency=low
 .
   [Sean Finney]
   * New upstream (git snapshot) release.
   * Remove autofoo generated content and create/remove it as part of the
     standard build process instead.
   * Similarly, add Build-Deps on autoconf and similar stuff.
   * Remove the old/buggy compiz.wrapper script and now use Kristian Lyngstol's
     compiz-manager script as a drop-in replacement for it.  This should fix
     numerous problems with plugin settings and window decorators not behaving
     properly.  specifically, it closes: #449389, #390929, #400583, #440095.
     it also closes: #446901, #447345 closes: #393501, #445026.
   * Update copyright file accordingly.
Files: 
 91354a0f2b86691825e0d8e5a2420f9e 1527 x11 optional compiz_0.6.3~git20071208.25941d14-1.dsc
 a90da9cb5e30718c495e66dde1103825 995936 x11 optional compiz_0.6.3~git20071208.25941d14.orig.tar.gz
 9923a9a8d29fd75adcdbb8261a7cb694 16591 x11 optional compiz_0.6.3~git20071208.25941d14-1.diff.gz
 e4e043659d413117ac8548e7ad8f3a68 25772 x11 optional compiz_0.6.3~git20071208.25941d14-1_all.deb
 b06da115a668def473a3c82c50886ec0 409064 x11 optional compiz-core_0.6.3~git20071208.25941d14-1_amd64.deb
 a5f89daa0e9470246427188c098b5f88 49976 x11 optional compiz-dev_0.6.3~git20071208.25941d14-1_amd64.deb
 a6a2e5db88eb0dd7a2caa49d588d9bfd 67350 x11 optional compiz-gtk_0.6.3~git20071208.25941d14-1_amd64.deb
 06852a2475f897016677b0d38f3e0b96 82980 x11 optional compiz-kde_0.6.3~git20071208.25941d14-1_amd64.deb
 b8907418f893cd6f25e6e70ef3d060f5 34492 x11 optional compiz-gnome_0.6.3~git20071208.25941d14-1_amd64.deb
 226ac3c3f9cf6bdcfb1cb8d0f45d58da 333720 x11 optional compiz-plugins_0.6.3~git20071208.25941d14-1_amd64.deb
 49394216a63fd3388534f0e5c3125a83 43656 x11 optional libdecoration0_0.6.3~git20071208.25941d14-1_amd64.deb
 f194e5d670e7bb4a69115a7820bbff6d 31638 x11 optional libdecoration0-dev_0.6.3~git20071208.25941d14-1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHZV09ynjLPm522B0RAkw8AJ48O2EhL9wz/zSNtq5UWPxBslF4xwCfc3sg
wxQGER4vN/3kfOUXTN76ttE=
=VndB
-----END PGP SIGNATURE-----



--- End Message ---

Reply to: