[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#443111: laptop: can't set brightness from within X11

On Sat, Sep 22, 2007 at 19:01:08 +0200, Dirk Griesbach wrote:

> Now I had the time to test 2.0.0; 2.1.0 and 2.1.1 with the following
> results:
> With every 2.x.x release I could use xbacklight. Nice work, because with
> it I can use much more brightness settings than the 8 steps provided by
> the manufacturer of my laptop through ACPI.
> With 2.0.0 I can additionally use the ACPI keys. E.g. I did set the
> brightness with `xbacklight  -set 20` to 20% and was able to use the
> ACPI keys to switch brightness from 20% (which then was the maximum for
> ACPI) in 8 steps to a minimum. This is a really nice solution. And my
> buttons worked. ;-)
> With 2.1.0 and later the buttons refuse to work but xbacklight worked as
> expected.
> Is there any sense in changing the behaviour from version 2.0.0 to
> 2.1.0?

Well the changes were probably needed to fix other configurations...
FWIW, on my 945gm, xbacklight never worked, but the acpi keys do.  So
there are a lot of different bioses / chipsets with subtly different
behaviour and bugs, which makes these issues hard to deal with and


Attachment: signature.asc
Description: Digital signature

Reply to: