[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#442915: xserver-xorg-input-mouse: mouse dead with X41 Tablet PC

[forgot to CC the BTS]

Hi Brice,

Thank you for considering this bug.

Brice Goglin wrote:
> Ben Goodrich wrote:
>> Perhaps there is a larger problem in that I once tried
>> to mv xorg.conf to see if X would automatically
>> reconfigure itself to get the mouse working, but
>> X would not even start in that case.
> You should try to move your xorg.conf away (the X server should be able
> to start without any config file), unplug all external input devices,
> and see whether the bug still occurs. Once this is tested, we might know
> more about the bug could be.

This was the first thing I tried. Now, I have tried again by putting
xorg.conf and all my working backups of xorg.conf* into a tarball and
rebooting with everything unplugged. After about two seconds of blank
screen, it drops me back to the console login.

Surely, this error is registered in the logs. All I have found is that
at the end of /var/log/kdm.log, it says:

X.Org X Server 1.4.0
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux Debian (xorg-server 2:1.4-2)
Current Operating System: $(uname -a)
Build Date: 16 September 2007 02:37:21PM

       Before reporting problems, check http://wiki.x.org
       to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
       (++) from command line, (!!) notice, (II) informational,
       (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file:/ "var/log/Xorg.0.log", Time: Mon Sep 17 19:56:20 2007
(EE) Unable to locate/open config file
New driver is "intel:
(==) Using default build-in configuration (55 lines)
(WW) intel: No matchig Device section for instance (BusID PCI:0:2:1) found

Fatal server error:
Cannot run in framebuffer mdoe. Please specify busIDs   for all
framebuffer devices


I do not understand this message too well, but it is possible that the
PCI stuff that makes it possible to write on the screen of a Tablet PC
is causing this error.

But as far as I can tell, xserver and the intel graphics drivers are
fine (when there is a xorg.conf available). But, the mouse also does not
work regardless of whether a USB mouse is plugged in when it boots. On
the other hand, I can move the "mouse" in init 3 with the gpm emulator.

Thanks again,

Reply to: