[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#426336: xorg: X fails to map legacy ROM on recent IA64 kernels

Peter Chubb wrote:
> Here it is.  But the problem is that X is trying to map a 1M region
> from location 0; on this machine you can't do that safely, so the
> kernel prevents it.


Note for the BTS: for the record, see the header of [1], the patch has
been merged in 2.6.22-rc1.

> X Window System Version 7.1.1
> Release Date: 12 May 2006
> X Protocol Version 11, Revision 0, Release 7.1.1
> Build Operating System: UNKNOWN 
> Current Operating System: Linux berry 2.6.21-rc5-g6d40fc51-dirty #20 SMP Mon May 28 10:48:11 EST 2007 ia64

Did you patch your 2.6.21-rc5 kernel with patches fron 2.6.22?

The corresponding fix has apparently been committed in Xorg in [2]. So
Xserver 1.2 and above should be ok. You appear to be running Xserver
1.1.1. Is there any chance you try xserver-xorg-core 1.3 currently in
unstable (you'll have to upgrade to libc6 2.5 to do so)? You could also
have tried an earlier xserver-xorg-core 1.2 from snapshot.debian.net but
I don't any 1.2 package built for ia64 there.



Reply to: