[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#257302: xfree86: general complaint about XFree86 on Dell LatitudeD400

Brice Goglin wrote:

About 3 years ago, you reported a bug to the Debian BTS regarding
general problems with XFree86 on a Dell Latitude D400.
Do you still have problems running X on this laptop? If not, I will
close this bug in the next weeks.


ît remains a pita.
I dunno exactly what was wrong then, it still doesn't do what I'd expect it to. Sarge, at least, still requires the installation of the 855wrap; otherwise it will just get completely frozen with a greenish screen. No need to file a report, since everyone knows. Call it a show-stopper for Aunt Tilly. I do understand that the developers / maintainers refuse to add that ugly hack that is underlying that wrapper. But then, at least, they ought to add a 'detector' and inform the user / booter that something won't work and stop; instead of leaving the machine full stuck with that screen.

Whenever I boot, whichever distro, the mouse will be detected properly, at /dev/input/mice (for the built-in touchpad as well as USB). Only on Debian I still get it at /dev/mouse (or similar), and it will fail to 'startx'. Even a server edition like OpenBSD did that correctly years ago on the same machine.

Up to you to close it, I guess, but it remains crap.

Thanks for asking; and keep the good work up, :)


Reply to: