[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#406318: SA23670: xorg: "DBE" and "Renderer" Extensions Vulnerabilities

Package: xorg
Version: 1:7.1.0-10
Severity: important
Tags: security

Sean Larsson has reported some vulnerabilities in X.Org X11, which can
be exploited by malicious, local users to gain escalated privileges.

The vulnerabilities are caused due to input validation errors within the
""ProcRenderAddGlyphs()" function of the "Renderer" extension and the
"ProcDbeGetVisualInfo()" and "ProcDbeSwapBuffers()" functions of the
"DBE" extension. This can be exploited to cause a memory corruption by
sending specially crafted X requests to the X server.

Successful exploitation may allow the execution of arbitrary code with
the privileges of the X server, but requires that the "Renderer" or
"DBE" extensions are loaded.

The vulnerabilities are reported in version 7.1-1.1.0. Other versions
may also be affected.

Update to version 7.2 RC3.


-- System Information:
Debian Release: 4.0
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-3-486
Locale: LANG=pt_BR.UTF-8, LC_CTYPE=pt_BR.UTF-8 (charmap=UTF-8)

  : :' :    Alex de Oliveira Silva | enerv
  `. `'     www.enerv.net

Reply to: