[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#381591: xterm: locale mode does not work



On Sat, Aug 05, 2006 at 07:30:09PM +0200, Stepan Golosunov wrote:
> Package: xterm
> Version: 210-3
> Severity: normal
> Tags: l10n
> 
> After upgrading from sarge to etch xterm stopped showing cyrillic
> characters and changed fonts. My .Xresources file contained

an up-to-date sarge would have xterm patch #200
 
> XTerm*locale: true
> XTerm*VT100.utf8Fonts.font: -xos4-terminus-medium-r-normal--20-200-72-72-c-100-iso10646-1
> XTerm*VT100.utf8Fonts.font2: -xos4-terminus-medium-r-normal--16-160-72-72-c-80-iso10646-1
> XTerm*VT100.utf8Fonts.font3: -misc-fixed-medium-r-normal--18-120-100-100-c-90-iso10646-1
> XTerm*VT100.utf8Fonts.font4: -xos4-terminus-medium-r-normal--20-200-72-72-c-100-iso10646-1
> XTerm*VT100.utf8Fonts.font5: -xos4-terminus-medium-r-normal--24-240-72-72-c-120-iso10646-1
> XTerm*VT100.utf8Fonts.font6: -xos4-terminus-medium-r-normal--28-280-72-72-c-140-iso10646-1
> 
> Running
> xterm -fn -xos4-terminus-medium-r-normal--20-200-72-72-c-100-iso10646-1
> worked, so I added

I have a hunch that this is related to the second part of the bug report.
 
> XTerm*VT100.font: -xos4-terminus-medium-r-normal--20-200-72-72-c-100-iso10646-1
> XTerm*VT100.font2: -xos4-terminus-medium-r-normal--16-160-72-72-c-80-iso10646-1
> XTerm*VT100.font3: -misc-fixed-medium-r-normal--18-120-100-100-c-90-iso10646-1
> XTerm*VT100.font4: -xos4-terminus-medium-r-normal--20-200-72-72-c-100-iso10646-1
> XTerm*VT100.font5: -xos4-terminus-medium-r-normal--24-240-72-72-c-120-iso10646-1
> XTerm*VT100.font6: -xos4-terminus-medium-r-normal--28-280-72-72-c-140-iso10646-1
> 
> to .Xresources. But this doesn't help with non-utf8 locales.
> Also xterm -lc now shows
> 
> xterm:  bad command line option "-lc"

That's a package problem.  Doing a 'strings' on xterm 210-3, I can see it's
missing the luit support.  Looking at the package diff's gives me the
configure options

	./configure \
		--enable-logging \
		--enable-wide-chars \
		--enable-256-color \
		--prefix=/usr \
		--exec-prefix=/usr \
		--mandir=/usr/share/man \
		--with-app-defaults=/etc/X11/app-defaults \
		--disable-imake \
		--enable-narrowproto

and building that, I get the same result:

	checking if you want to use mini-luit/Latin9 built-in support... no
	checking if you want to use luit... no

Doing either

	--enable-mini-luit
	--enable-luit

would enable luit.  That should be enabled.

-- 
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net

Attachment: pgpVRzG13BEFs.pgp
Description: PGP signature


Reply to: