[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#364599: libxt6: resource finding broken



Package: libxt6
Version: 1:1.0.0-4
Severity: important


In system-wide resource directory finding resources for <class>-<customization> is not
working.

$ LANG=C strace xterm 2>/tmp/xterm.log
$ cat /tmp/xterm.log
------------------------------------------------------------------------------------
...
access("/home/jek/C/XTerm-color", R_OK) = -1 ENOENT (No such file or directory)
access("/home/jek/XTerm-color", R_OK)   = -1 ENOENT (No such file or directory)
access("/home/jek/C/XTerm", R_OK)       = -1 ENOENT (No such file or directory)
access("/home/jek/XTerm", R_OK)         = -1 ENOENT (No such file or directory)
access("/usr/lib/X11/C/app-defaults/XTerm", R_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/X11/app-defaults/XTerm", R_OK) = -1 ENOENT (No such file or directory)
access("/etc/X11/C/app-defaults/XTerm", R_OK) = -1 ENOENT (No such file or directory)
access("/etc/X11/app-defaults/XTerm", R_OK) = 0
stat64("/etc/X11/app-defaults/XTerm", {st_mode=S_IFREG|0644, st_size=6921, ...}) = 0
open("/etc/X11/app-defaults/XTerm", O_RDONLY) = 4
...
------------------------------------------------------------------------------------


-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.14
Locale: LANG=be_BY.CP1251, LC_CTYPE=be_BY.CP1251 (charmap=CP1251)

Versions of packages libxt6 depends on:
ii  libc6                         2.3.6-7    GNU C Library: Shared libraries
ii  libice6                       1:1.0.0-3  X11 Inter-Client Exchange library
ii  libsm6                        1:1.0.0-4  X11 Session Management library
ii  libx11-6                      2:1.0.0-6  X11 client-side library
ii  x11-common                    1:7.0.14   X Window System (X.Org) infrastruc

libxt6 recommends no packages.

-- debconf information:
  libxt6/migrate_app_defaults_dir: true



Reply to: