[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#346098: xserver-xorg: EmulateWheelTimeout not working

:Package: xserver-xorg
:Version: 6.9.0.dfsg.1-1
:Severity: normal
:I was using the experimental packages for quite some time to get
:EmulateWheelTimeout (bug #320136 got me interested), and the
:packages worked great, incl. the EmulateWheelTimeout setting.
:After the change from to the
:setting stopped working (mailed a bugreport back on Nov 25th to one of
:the maintainers), hence I can't click any longer with the middle mouse
:button when using EmulateWheel on my Trackpoint device. The final 6.9
:release unfortunately didn't solve this either, still no go.
:The setting gets parsed just fine, value shows up correctly in
:Xorg.0.log, but the middle button does not send click events when
:checked with xev.
:Kind regards
:PS: FYI: the Emulate3Buttons is only in my config so I can circumvent
:the problem for now be using the good'ol left'n'right combo to get the
:middle click, doesn't work without it either.

I can verify this issue -- I'm using a ThinkPad A21e. With the package, the EmulateWheelTimeout setting is honored, and 
I can use button 2 on click and scroll horizontally and vertically on drag:

Section "InputDevice"                       
        Identifier      "Configured Mouse"
        Driver          "mouse"                    
        Option          "CorePointer"           "on"            
        Option          "Device"                "/dev/input/mouse0"
        Option          "Protocol"              "ExplorerPS/2"
        Option          "ZAxisMapping"          "4 5 6 7"
        Option          "EmulateWheelButton"    "2"                        
        Option          "EmulateWheel"          "on"
        Option          "EmulateWheelTimeout"   "300"
        Option          "YAxisMapping"          "4 5"
        Option          "XAxisMapping"          "6 7"

However, on upgrading to all the way up to the current 
version in unstable, 6.9.0.dfsg.1-2, this setting is parsed but ignored:

(**) Option "Protocol" "ExplorerPS/2"
(**) Configured Mouse: Device: "/dev/input/mouse0"
(**) Configured Mouse: Protocol: "ExplorerPS/2"
(**) Option "CorePointer" "on"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mouse0"
(==) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5 6 7"                          
(**) Configured Mouse: ZAxisMapping: buttons 4, 5, 6 and 7
(**) Option "EmulateWheel" "on"                                   
(**) Option "EmulateWheelButton" "2"                        
(**) Option "EmulateWheelTimeout" "300"                       
(**) Option "XAxisMapping" "6 7"                                
(**) Configured Mouse: XAxisMapping: buttons 6 and 7          
(**) Option "YAxisMapping" "4 5"                                                
(**) Configured Mouse: YAxisMapping: buttons 4 and 5
(**) Configured Mouse: EmulateWheel, EmulateWheelButton: 2, EmulateWheelInertia:
 10, EmulateWheelTimeout: 300                        
(**) Configured Mouse: Buttons: 7                     

Even with ridiculously high timeouts (30000 ms), the Button 2 event is never 

Currently I have downgraded to the experimental package 
and set it to be held back:
and it appears to work well for now.

Having Emulate3Buttons on is handy even when click-or-scroll allows click 
events to be sent, because this eliminates the middle button drag event, 
which can be useful when scrolling xterms using the scrollbar, among other 
things. (Emulate3Buttons has its own drawbacks, since it eliminates the 
ability to have Button 1 and 3 Down events simultaneously -- which can put a 
damper on FPS gaming . . . not that that's an issue with a laptop 
trackpoint, of course.)

(FYI, I didn't know about this option until today -- so far I'd been using 
tp-scroll to kludge on the click-or-scroll behavior, but the native support 
is so much better, hence my need to go to snapshot.debian.net for the 
experimental package.)


Amit Gurdasani

Reply to: