[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#345640: xserver-xorg: New Xorg crashes with kernel 2.6.14, but not with 2.6.12


  Sorry for the delay in replying... I tried as you said and now Xorg
does work with the 2.6.14 kernel:D.
  However, I also noticed that this was a problem only in my Latitude
D610, but not in my office's laptop (Thinkpad R40), which works without
problem even with DRI enabled in xorg.conf and the X.14 kernel with the
newest xserver...

    Thanks very much!!


On Wed, 2006-01-04 at 16:52 +0100, Michel Dänzer wrote:
> On Tue, 2006-01-03 at 00:44 -0500, Patricio Rojo wrote:
> > Package: xserver-xorg
> > Version: 6.8.2.dfsg.1-11
> > Followup-For: Bug #345640
> > 
> > Hi,
> > 
> >   I think I run into this same problem... I upgraded the kernel from 
> > 2.6.12 to 2.6.14 maybe one hour after upgrading the xserver, so I was 
> > able to have a working xserver for a little bit, which hinted me to 
> > look for a better cause for the crash.
> >   What happens in my Dell Latitude D610 is that Xorg starts using 99.7% 
> > of the CPU and never shows anything else than a blank screen. Xorg 
> > cannot be killed or terminated (signals 9 or 15), but it can be reniced 
> > so that other programs can be run remotely without taking forever.
> > 
> >   The problem can be solved by either booting with kernel 2.6.12 or 
> > by downgrading the package xserver-xorg to 6.8.2.dfsg.1-11 (and only 
> > that package, without any of the other accompanying libs) 
> >   In summary xorg 6.9.0.dfsg.1-1 works only with kernel 2.6.12, while 
> > 6.8.2.dfsg.1-11 works with both kernels.
> This is probably because X.Org 6.9 and kernel 2.6.14 support the DRI on
> Radeon 9500 and newer. Try not enabling the DRI, i.e. not loading the
> "dri" module in xorg.conf.

Reply to: