[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#342817: Apparent hang of X.org with the nv open source driver

On Thu, Dec 15, 2005 at 03:26:20PM -0500, David Nusinow wrote:
> On Thu, Dec 15, 2005 at 11:53:54AM -0800, Ross Boylan wrote:
> > > Ross, I've not worked on RC3 mainly because there didn't seem to be a need
> > > for it. I'll try and get RC3 in to the svn repo and uploaded to
> > > experimental ASAP so you can test whether or not it fixes your issue.
> > 
> > >  - David Nusinow
> > Thanks.  Will it be safe to install the debs from experimental, or
> > should I rebuild from source on testing?  The flux in the toolchain
> > makes me a bit nervous, though I guess that's mostly a matter for C++
> > and X is C.
> Yes, it should work fine. I'm running an unstable system with the
> experimental Xorg packages here with no issues, so I think you should be Ok. Besides, who really wants to build all of X? :-)
> The RC3 packages are in incoming right now. Sorry it took so long to get
> them up, I had strange issues with building the packages.
>  - David Nusinow

I just tried installing xserver-xorg and xserver-common from
experimental at  The changelog indicates this is
RC3.  Still no luck.  I believe I made the appropriate modifications
to xorg.conf as I switched between the proprietary (nvidia) and open
(nv) drivers.  I verified that vga worked in the configuration for
which nv failed as a check.  I ran startx as root, rather than, e.g.,
kdm start.  However, no glcore load was generated by the initial setup
of xorg.conf, and I haven't added it.

The failure acts a bit differently than the original high CPU in this
bug's title; now it seems to just die without leaving any informative

BTW, nvidia-glx is not compatible even with the experimental version
of xserver-xorg.  This seems a bit odd, because it is compatible with
the 6.8.2.dfsg.1-11+SVN debs I built from source.  It is also
incompatible with the current testing version of xserver-xorg.

I know proprietary drivers are not supported, but I had thought from
other bugs/exchanges that the mainline debian X packages and the
proprietary nvidia ones had managed to arrange co-existence.  At the
moment, that's essential for me, since the proprietary drivers are the
only ones that are working.


Reply to: