[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#337221: xserver-xorg: undefined colors render important apps unusable

severity 337221 normal

On Thu, Nov 03, 2005 at 05:48:58AM -0500, Antonio Rodríguez wrote:
> Package: xserver-xorg
> Version: 6.8.2.dfsg.1-10
> Severity: critical
> Justification: breaks unrelated software

No. This is not a critical bug, especially because with tons of successful
upgrade reports you're the only one to have this problem.

> After doing some research following the advice given in
> http://lists.debian.org/debian-user/2005/11/msg00170.html
> I discovered that the file /etc/X11/rgb.txt didn't exist
> ls /etc/X11/rgb.txt
> ls: /etc/X11/rgb.txt: No such file or directory
> however, there was a symlink pointing to it
> ls -l /usr/X11R6/lib/X11/rgb.txt
> lrwxrwxrwx  1 root root 16 2005-11-01 20:11 /usr/X11R6/lib/X11/rgb.txt
> -> /etc/X11/rgb.txt
> In the thread other people have reported to have the file rgb.txt
> http://lists.debian.org/debian-user/2005/11/msg00247.html
> Perhaps the upgrade failed to install it, don't know exactly whats going
> on.
> Versions of packages xserver-xorg depends on:
> ii  debconf [debconf-2.0]    1.4.58          Debian configuration management sy
> ii  libc6                    2.3.5-7         GNU C Library: Shared libraries an
> ii  libgcc1                  1:4.0.2-3       GCC support library
> ii  libxau6                  6.8.2.dfsg.1-10 X Authentication library
> ii  libxdmcp6                6.8.2.dfsg.1-10 X Display Manager Control Protocol
> ii  xserver-common           6.8.2.dfsg.1-10 files and utilities common to all 
> ii  zlib1g                   1:1.2.3-6       compression library - runtime
> Versions of packages xserver-xorg recommends:
> ii  discover1                1.7.15          hardware identification system
> ii  laptop-detect            0.12.1          attempt to detect a laptop
> ii  mdetect                 mouse device autodetection tool
> ii  xlibs                    6.8.2.dfsg.1-10 X Window System client libraries m

You *really* need to install x11-common, just like I told you the first
time you asked us this question. I don't know why it wasn't installed for
you, since it seems to have worked fine for everyone else. I assume that
your libx11 wasn't upgraded either, since it depends on x11-common, but I
have no idea why. 

Did you hold back any of the X libs or simply never upgrade them when going
to sid? Do you still have sarge sources in your sources.list? Are you
pinned incorrectly? There's a number of things that could have gone wrong
here and I'm at a loss to figure them out, since this should have worked

 - David Nusinow

Reply to: