[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#318015: marked as done (xserver-xorg: dies in preinst due to debconf bug)



Your message dated Sat, 30 Jul 2005 16:41:20 -0400
with message-id <20050730204120.GE8481@squee.verizon.net>
and subject line Closing. Not an Xorg bug.
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 12 Jul 2005 21:28:31 +0000
>From sesse=submit=bugs.debian.org=vmdqrfcb@samfundet.no Tue Jul 12 14:28:31 2005
Return-path: <sesse=submit=bugs.debian.org=vmdqrfcb@samfundet.no>
Received: from cassarossa.samfundet.no [129.241.93.19] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1DsSIn-0000UA-00; Tue, 12 Jul 2005 14:28:29 -0700
Received: from trofast.ipv6.sesse.net ([2001:700:300:dc03:20e:cff:fe36:a766] helo=trofast.sesse.net)
	by cassarossa.samfundet.no with esmtp (Exim 4.50)
	id 1DsSIk-000684-FW
	for submit@bugs.debian.org; Tue, 12 Jul 2005 23:28:27 +0200
Received: from sesse by trofast.sesse.net with local (Exim 3.36 #1 (Debian))
	id 1DsSIj-0000TB-00
	for <submit@bugs.debian.org>; Tue, 12 Jul 2005 23:28:25 +0200
Date: Tue, 12 Jul 2005 23:28:25 +0200
From: "Steinar H. Gunderson" <sgunderson@bigfoot.com>
To: submit@bugs.debian.org
Subject: xserver-xorg: dies in preinst due to debconf bug
Message-ID: <20050712212825.GA1452@uio.no>
Mime-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Disposition: inline
X-Operating-System: Linux 2.6.11.8 on a i686
X-Message-Flag: Outlook? --> http://www.mozilla.org/products/thunderbird/
User-Agent: Mutt/1.5.9i
X-Spam-Score: -2.8 (--)
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-Spam-Level: 

Package: xserver-xorg
Version: 6.8.2.dfsg.1-1
Severity: serious

After first doing "aptitude install xserver-common" and then "aptitude
install xserver-xorg" (just "aptitude dist-upgrade" wanted to remove
~300 packages, including GNOME :-) ), I got:

   xserver-xorg config warning: migrating xserver-xfree86 templates to xserver-xorg.
   Can't call method "choices" on an undefined value at
   /usr/share/perl5/Debconf/Question.pm line 85, <GEN13> line 118.

   Received signal.  Aborting xserver-xorg package config script.

Then, it installed some other packages, and tried again, giving
essentially the same error:

   xserver-xorg config warning: migrating xserver-xfree86 templates to xserver-xorg.
   Can't call method "choices" on an undefined value at
   /usr/share/perl5/Debconf/Question.pm line 85, <GEN1> line 115.

Some manual debugging with DEBCONF_DEBUG=developer revealed:

[...]
debconf (developer): <-- SET xserver-xorg/autodetect_monitor true
debconf (developer): --> 0 value set
debconf (developer): <-- FSET xserver-xorg/autodetect_monitor seen true
debconf (developer): --> 0 true
debconf (developer): <-- METAGET xserver-xfree86/config/display/modes choices
Can't call method "choices" on an undefined value at
/usr/share/perl5/Debconf/Question.pm line 85, <GEN1> line 115.

Now, this does indeed exist in debconf:

  Name: xserver-xfree86/config/display/modes
  Template: xserver-xfree86/config/display/modes
  Value: 800x600, 640x480
  Owners: xserver-xfree86

However, there are no choices there, actually... and I can't find
anything in the templates, either. I guess the problem is:

baby:~/xorg> grep -c config/display/modes /var/cache/debconf/templates.dat
0

So, the template in question is kind of half-there, since it has a _value_
but not a template. Now, debconf shouldn't _die_ on this, and that is
probably a bug (I guess I'll kick Joey when I see him later today :-) ),
for in the meantime this breaks X.org installation in these cases...

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-3-686
Locale: LANG=nb_NO.UTF-8, LC_CTYPE=nb_NO.UTF-8 (charmap=UTF-8)

-- no debconf information

-- 
Homepage: http://www.sesse.net/

---------------------------------------
Received: (at 318015-done) by bugs.debian.org; 30 Jul 2005 20:41:24 +0000
>From naughtynus@verizon.net Sat Jul 30 13:41:24 2005
Return-path: <naughtynus@verizon.net>
Received: from vms040pub.verizon.net [206.46.252.40] 
	by spohr.debian.org with esmtp (Exim 3.36 1 (Debian))
	id 1Dyy96-0007lN-00; Sat, 30 Jul 2005 13:41:24 -0700
Received: from squee ([68.160.39.108])
 by vms040.mailsrvcs.net (Sun Java System Messaging Server 6.2 HotFix 0.04
 (built Dec 24 2004)) with ESMTPA id <0IKG00KM3K4WCFIK@vms040.mailsrvcs.net> for
 318015-done@bugs.debian.org; Sat, 30 Jul 2005 15:41:20 -0500 (CDT)
Received: by squee (Postfix, from userid 1000)	id ABD7B46D4E; Sat,
 30 Jul 2005 16:41:20 -0400 (EDT)
Date: Sat, 30 Jul 2005 16:41:20 -0400
From: David Nusinow <david_nusinow@verizon.net>
Subject: Closing. Not an Xorg bug.
To: 318015-done@bugs.debian.org
Message-id: <20050730204120.GE8481@squee.verizon.net>
MIME-version: 1.0
Content-type: text/plain; charset=us-ascii
Content-disposition: inline
User-Agent: Mutt/1.5.9i
Delivered-To: 318015-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level: 
X-Spam-Status: No, hits=-3.0 required=4.0 tests=BAYES_00 autolearn=no 
	version=2.60-bugs.debian.org_2005_01_02

This isn't a bug in xorg but rather in debconf and there appears to be no
way to work around it from within the xorg scripts. The debconf maintainer
says that this problem in debconf is known but is unreproducible, and can
be fixed by running /usr/share/debconf/fix_db.pl. Since this is totally out
of the XSF's hands, I'm closing this bug.

 - David Nusinow



Reply to: