[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#282435: xfree86 cannot find /dev/psaux after install of kernel-image-2.6.8-1-k7

On Mon, Nov 22, 2004 at 09:46:53PM -0500, xucaen wrote:
> Package: kernel-image-2.6.8-1-k7
> Status: install ok installed
> Priority: optional
> Section: base
> Installed-Size: 44108
> Maintainer: Debian kernel team <debian-kernel@lists.debian.org>
> Architecture: i386
> Source: kernel-image-2.6.8-i386
> Version: 2.6.8-5
> Provides: kernel-image, kernel-image-2.6
> Depends: initrd-tools (>= 0.1.63), coreutils | fileutils (>= 4.0),
> module-init-tools (>= 0.9.13)
> Suggests: lilo (>= 19.1) | grub, fdutils, kernel-doc-2.6.8 |
> kernel-source-2.6.8
> Conflicts: hotplug (<< 0.0.20040105-1)
> Description: Linux kernel image for version 2.6.8 on AMD K7.
> Hi, sorry about not providing the required information. I've never
> submitted a bug report before. I'm not entirely certain I even need to
> send this but the error message I received said I should send the
> /var/log/XFree86.0.log to you. I am still researching this out on the
> web to find what I need to do to fix this.
> Everything is working smoothly. But XFree86 fails to load and 
> gives me these errors:
>  (EE) xf86OpenSerial: Cannot open device /dev/psaux
>          No such device.
>  (EE) Configured Mouse: cannot open input device
>  (EE) PreInit failed for input device "Configured Mouse"
>  No core pointer
>  from what i've been able to gather, /dev/psaux no longer is used by the
> new kernel 2.6. I am unable to find steps to take to change my
> configuration. I did find a that "modprob mousedev psaux=1" make the
> mouse work again.
> I found in the kernel 2.6.8 docs that I need to make sure that both
> psmouse and mousedev modules are installed. I ran modconf and discovered
> that psmouse is installed but there was no mousedev on the list. I have
> verified that the new module-init-tools package is installed
> Package: module-init-tools
> Version: 3.1-pre6-1
> I am attaching  attach /var/log/XFree86.0.log

A work around that worked for _me_ on several systems
was to insmod mousedev (and possibly also psmouse).
I believe there are plenty of others. I am pretty certain
it isn't a kernel bug as such. 


Reply to: