[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#266074: xlibs-dev: dependency problem with several other X library packages



tag 266074 + moreinfo
severity 266074 normal
thanks

On Mon, Aug 16, 2004 at 06:12:12PM +0200, Dan Chiavelli wrote:
> Package: xlibs-dev
> Severity: important

Why is your installed version of xlibs-dev not reported above?

What version of xlibs-dev do you have installed, or what version are you
trying to install?

> I think the dependencies have gotten messed up for xlibs-dev... all of 
> the dependent packages are off by one minor version number.  Please 
> pardon the copious output, but it describes the problem much better than 
> I can:
> 
> root@mongoose# apt-get install xlibs-dev
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> 
> Since you only requested a single operation it is extremely likely that
> the package is simply not installable and a bug report against
> that package should be filed.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>   xlibs-dev: Depends: libice-dev but it is not going to be installed
>              Depends: libsm-dev but it is not going to be installed
>              Depends: libx11-dev but it is not going to be installed
>              Depends: libxext-dev but it is not going to be installed
>              Depends: libxi-dev but it is not going to be installed
>              Depends: libxmu-dev but it is not going to be installed
>              Depends: libxmuu-dev but it is not going to be installed
>              Depends: libxp-dev but it is not going to be installed
>              Depends: libxpm-dev but it is not going to be installed
>              Depends: libxrandr-dev but it is not going to be installed
>              Depends: libxt-dev but it is not going to be installed
>              Depends: libxtrap-dev but it is not going to be installed
>              Depends: libxtst-dev but it is not going to be installed
>              Depends: libxv-dev but it is not going to be installed
>              Depends: xlibs-static-dev but it is not going to be 
> installed
> E: Broken packages
> 
> root@mongoose# apt-get install libice-dev libsm-dev libx11-dev
> libxext-dev libxi-dev libxmu-dev libxmuu-dev libxp-dev libxpm-dev
> libxrandr-dev libxt-dev libxtrap-dev libxtst-dev libxv-dev
> xlibs-static-dev
> 
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>   libice-dev: Depends: libice6 (= 4.3.0.dfsg.1-4) but 4.3.0.dfsg.1-5 is 
> to be installed
>   libsm-dev: Depends: libsm6 (= 4.3.0.dfsg.1-4) but 4.3.0.dfsg.1-5 is to 
> be installed
>   libx11-dev: Depends: libx11-6 (= 4.3.0.dfsg.1-4) but 4.3.0.dfsg.1-5 is 
> to be installed
>   libxext-dev: Depends: libxext6 (= 4.3.0.dfsg.1-4) but 4.3.0.dfsg.1-5 
> is to be installed
>   libxi-dev: Depends: libxi6 (= 4.3.0.dfsg.1-4) but 4.3.0.dfsg.1-5 is to 
> be installed
>   libxmu-dev: Depends: libxmu6 (= 4.3.0.dfsg.1-4) but 4.3.0.dfsg.1-5 is 
> to be installed
>   libxmuu-dev: Depends: libxmuu1 (= 4.3.0.dfsg.1-4) but 4.3.0.dfsg.1-5 
> is to be installed
>   libxp-dev: Depends: libxp6 (= 4.3.0.dfsg.1-4) but 4.3.0.dfsg.1-5 is to 
> be installed
>   libxpm-dev: Depends: libxpm4 (= 4.3.0.dfsg.1-4)
>   libxrandr-dev: Depends: libxrandr2 (= 4.3.0.dfsg.1-4) but 
> 4.3.0.dfsg.1-5 is to be installed
>   libxt-dev: Depends: libxt6 (= 4.3.0.dfsg.1-4) but 4.3.0.dfsg.1-5 is to 
> be installed
>   libxtrap-dev: Depends: libxtrap6 (= 4.3.0.dfsg.1-4) but 4.3.0.dfsg.1-5 
> is to be installed
>   libxtst-dev: Depends: libxtst6 (= 4.3.0.dfsg.1-4) but 4.3.0.dfsg.1-5 
> is to be installed
>   libxv-dev: Depends: libxv1 (= 4.3.0.dfsg.1-4) but 4.3.0.dfsg.1-5 is to 
> be installed
> E: Broken packages
> 
> Thanks for your attention...

It looks to me like you might have at some point been running unstable,
then backed your system down to sarge while leaving several unstable
packages (like libice6, libsm6, etc.) installed.  After switching to sarge,
which still has -4 in it, you then attempted to install xlibs-dev.

Does that sound right?

If so, there is not a bug here.  You need to downgrade your X library
packages, or run unstable again (where 4.3.0.dfsg.1-6 is the current
version).

-- 
G. Branden Robinson                |
Debian GNU/Linux                   |           If ignorance is bliss,
branden@debian.org                 |           is omniscience hell?
http://people.debian.org/~branden/ |

Attachment: signature.asc
Description: Digital signature


Reply to: