[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#266336: xterm changes meta-X to meta-8 in en_US.UTF-8 locale



On Tue, Aug 17, 2004 at 06:00:15PM +0200, Andrew Moise wrote:
> Package: xterm
> Version: 4.3.0.dfsg.1-6
> Severity: normal
> 
>   When I run emacs inside an xterm which was started in the en_US.UTF-8 locale, 
> and press alt-X, emacs seems to receive a meta-8 keypress instead of a meta-X
> keypress.  When I start the xterm in the en_US.ISO-8859-1 locale instead, alt-X
> is correctly received as meta-X (as it is when I run emacs in its own X
> window).

Perhaps you have a resource setting confusing things.  I see the proper
symbol (a lowercase "o" with a slash through it).  The eightBitInput and
metaSendsEscape resources related to "meta-X" (sending an escape character
before the code).

However, the reference to 4.3.0.dfsg.1-6 sounds more as if you're running
into problems with modifiers (a library issue).

>   This sounds like it could be related to #135075, BTW.

no (I read that report, and it looks different).

-- 
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net

Attachment: pgpFDF8KmOGjf.pgp
Description: PGP signature


Reply to: