[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#253172: xserver-xfree86: Cannot install (preinst fails)

Package: xserver-xfree86
Version: 4.3.0.dfsg.1-4
Severity: critical
Justification: breaks the whole system

When trying to install xserver-xfree86, the install fails with the error
message that the preinstallation script returned with error code 127.
Trying to use 4.3.0.dfsg.1-1 instead results in the same problem; however
with earlier versions (before .dfsg, but don't ask me the exact version)
i never had this problem. Purging the package (and xserver-common) does
not help.

This is a critical issue because i nowadays use X clients quite
regularly. :)

I had a quick skim through the preinst script, but did not find anything
immediately obvious. Is there a good way to debug preinst scripts ?

I should probably also mention that i use the nvidia binary drivers, but
as this doesn't seem to be a file conflict, i don't think it is related.

I would also be quite happy already if you could point me to an older
copy of xserver-xfree86 (older than what currently is in testing).


-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.5-fermat.03
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro

Reply to: