[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#250655: xterm: crashes on paste from abiword



On Fri, May 28, 2004 at 05:17:45AM -0500, Branden Robinson wrote:
> On Wed, May 26, 2004 at 05:03:43PM -0400, Thomas Dickey wrote:
> > On Wed, May 26, 2004 at 03:10:08AM +0200, Thomas Dickey wrote:
> > 
> > Running xterm against current XFree86, this problem does not appear.
> 
> By "current XFree86", do you mean Debian's latest packages of it,
> XFree86 4.4.0, or XFree86 CVS HEAD?

I was looking at the latter.  (I do have a build tree for 4.4.0, but since I
made a few fixes for Xt, was looking at the current code, partly to see if
there were other fixes I might make).

unrelated - I'm using a static copy of XFree86 for my X server on Debian (can't
recall entirely at the moment, but the previous set of X packages didn't
successfully start X, but seem to recall that the current one does).

Both current XFree86 server and current Debian libraries have problems though
(I have observed that the current Debian libraries are causing Opera to use a
lot of CPU, and also went back to a previous snapshot of my X servers to avoid
a bug - debugging the server is out of my range of interests).

I do a full build on each xterm patch check xterm and to update the XFree86
binary.  When I was testing this report, it was against the build tree, since
(if I'd seen an issue) it would be simple to recompile the related libraries
with -g so valgrind could offer more insight).  Since I already have the
trees setup, it was the least work (but doesn't completely answer the
report of course).

-- 
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net

Attachment: pgphuXiFNFSM1.pgp
Description: PGP signature


Reply to: