[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#233867: "Provides: xlib6g" needed in 4.3.0

On Fri, Feb 20, 2004 at 11:16:35AM -0500, Branden Robinson wrote:
> On Fri, Feb 20, 2004 at 02:35:41PM +0200, Martin-???ric Racine wrote:
> > I have an old Netscape 4.77 dating back from Potato that I absolutely
> > 
> > Alternately, if some existing 4.3.0 packages are supposed to
> > "Provides: xlib6g, libxaw6" this might work. If this is possible,
> I am sorry, but the xlib6g package name is was deprecated in the woody
> release and will be entirely absent in sarge.
> You may be able to rectify your problem, however, by using the "equivs"

Well, the problem is: as long as you Conflict: xlib6g
in xlibs, nobody will be able to install any package
that even just Provides: xlib6g.
That's why the way you suggest just simply does not
(And yes, I tried it, I did build my own fake-xlib6g
with Provides: xlib6g).

That was my reason for 233818.

There is no other chance currently, than repackage any
package that depends on xlib6g currently with modified
control file.

The question is: Since the last xlib6g packages are
empty packages anyways... do you really need to
Conflict: it?

<delta> talk softly and carry a keen sword

Reply to: